link to "Change log" from found file in mxr gives bad URL

VERIFIED FIXED

Status

Webtools
MXR
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Ray Kiddy, Assigned: timeless)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
to reproduce:

- go to http://mxr.mozilla.org
- click "Mozilla Central'
- type "PrefsFile4xAsFileSpec" in the 'Search For' box. This choice is random and illustrates the bug.
- click on the "View _change log_" link next to the listing for "/profile/pref-migrator/src/nsPrefMigration.cpp"

You will get a 404 because this is not a valid URL:

http://hg.mozilla.org/mozilla-central/mozilla-central/?log/tip/profile/pref-migrator/src/nsPrefMigration.cpp

It points out that "mozilla-central/mozilla-central" is not found.
(Reporter)

Updated

10 years ago
Summary: link to "Change log" gives bad URL → link to "Change log" from found file in mxr gives bad URL
Assignee: mitchell → bear
Component: Miscellaneous → LXR
Product: mozilla.org → Webtools
QA Contact: miscellaneous → lxr
timeless, you broke this.
Assignee: bear → timeless
OS: Mac OS X → All
Hardware: PC → All
(Reporter)

Comment 2

10 years ago
Wow. I found a real bug? Who'd a thunk it.... :-)
(Assignee)

Comment 3

10 years ago
yeah, this was a bug - fixed in:
changeset 69  	6e011efd875f
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: regression
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.