Video MV4 file does not open with its associated Tools/Options/Application

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: John Straker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0

This worked in FF2.x but not after the upgrade to FF3

Instead the browser tries to open the video file directly, e.g

ftypM4V ���M4V M4A mp42isom���mdat�F�~mdat�����I����@������N�
Kܡ�:�ԛ����

Shows the first two lines.

The associated application is VLC Media Player 0.8.6d


Reproducible: Always

Steps to Reproduce:
1. Subscribe to the RSS feed http://www.euronews.net/en/nocomment/
2. Click on the video feed link in the RSS browser

Actual Results:  
1. Observe the browser ignores the associated application and opens the video source directly.
2. Stop the load by clicking the X stop button on the toolbar.

Expected Results:  
The VLC application should have opened the video feed and the browser should have loaded a blank:blank dummy session.
This can not work in FF2 because this is a server error.
Example link :
http://www.euronews.net/podcasts/nocomment/nocom-NC0504-0607-deutschland_VI.m4v

HTTP Status Code: HTTP/1.1 200 OK
Server:	Apache/2.2.3 (CentOS)	
Last-Modified:	Sun, 06 Jul 2008 08:07:04 GMT	
ETag:	"cf0095-4746a3-71bb9a00"	
Accept-Ranges:	bytes	
Content-Length:	4671139	
Content-Type:	text/plain; charset=utf-8	
Date:	Mon, 07 Jul 2008 20:38:25 GMT	
Connection:	close

They send the video as text/plain and Gecko displays this as text/plain and that is correct. The sever should send the Video with a correct mime-type.

marking invalid, i contacted them with the webform on their page and I hope that they will fix this error.


Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.