After I sign out, Weave status bar label is "Sign in" instead of "Offline"

RESOLVED WORKSFORME

Status

Cloud Services
General
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

unspecified
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Steps to reproduce:
0. (if you don't already have this set) In Weave preferences, uncheck "Automatically connect each time you start Firefox" and restart firefox.
1. Start Firefox, and examine weave status bar area
  --> status is "Offline"
2. Sign in to weave. (Click weave status icon, and select "Sign in")
3. Sign out of weave. (Click weave status icon, and select "Sign out")

ACTUAL RESULTS:
  Status area of weave now says "Sign in".

EXPECTED RESULTS:
  Status are of weave should show "Offline" (to match the status label for the initial logged-out state)
(Reporter)

Comment 1

10 years ago
> EXPECTED RESULTS:
>   Status are of weave should show "Offline" (to match the status label for the
> initial logged-out state)

Alternately, the initial "Offline" status label could be changed to "Sign in", or they could both be changed to some other label.  My point is that they should have the same name, because (AFAIK) they indicate the same state.
(Reporter)

Comment 2

10 years ago
VERSION INFO:
 * Weave 0.2.0
 * Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1pre) Gecko/2008061804
GranParadiso/3.0.1pre
 * Ubuntu Linux 8.04
(Reporter)

Comment 3

10 years ago
This bug persists in Weave 0.2.4, and it has interesting effects when there are multiple windows.

If I have multiple windows open when I log in to Weave, the status labels on all windows all will change to [weave username].  Then when I log out, their status label all change to "Sign In".

Then -- here's the interesting part -- if I open a new window at that point (when I'm logged out), the *new* window's status is "Offline", even though the existing windows all show "Sign In".  

So then I have a mix of windows with "Sign In" and "Offline" statuses (depending on when the windows were created).

Updated

9 years ago
Target Milestone: -- → Future

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
It is now "Not Signed In" in all cases.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.