Status

SeaMonkey
General
P3
blocker
VERIFIED DUPLICATE of bug 44342
18 years ago
14 years ago

People

(Reporter: Jerry Baker, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla will only run one time if I use the classic skin (not sure if it's 
related, but I always use the classic skin). If I try to run it after having 
already ran it once, it just shows up in my task manager, but no window ever 
appears. Using -console, I get 

------------------------------------------
stdout directed to dynamic console
stderr directed to dynamic console
WEBSHELL+ = 1
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback error: Can't initialize.
WEBSHELL+ = 2
------------------------------------------

I have tried deleting Users50, mozregistry.dat and mozver.dat. The only thing 
that works is to delete the entire bin directory and re-unzip it. I already 
thought that it might be component.reg, so I tried that too. No such luck.

I am working on a debug build now to see if it does it there too, but I suspect 
that it will not.

Not sure of the component, so setting Browser - General for assignment.
(Reporter)

Comment 1

18 years ago
Sorry. Last tested on 2000-06-30-21 Win32-Talkback.
(Reporter)

Comment 2

18 years ago
Does it with debug builds too. Here is the console output:

nsNativeComponentLoader: autoregistering begins.
*** Registering nsAbSyncModule components (all right -- a generic module!)
*** Registering nsAbModule components (all right -- a generic module!)
*** Registering appshell components (all right -- a generic module!)
*** Registering nsAutoCompleteModule components (all right -- a generic module!)

*** Registering nsBookmarkModule components (all right -- a generic module!)
*** Registering nsSecurityManagerModule components (all right -- a generic modul
e!)
*** Registering CharDet components
*** Registering nsChromeModule components (all right -- a generic module!)
*** Registering nsCookieModule components (all right -- a generic module!)
*** Registering nsDirectoryViewerModule components (all right -- a generic modul
e!)
*** Registering nsEditorModule components (all right -- a generic module!)
*** Registering nsMimeEmitterModule components (all right -- a generic module!)
*** Registering nsNativeAppModule components (all right -- a generic module!)
*** Registering nsExternalProtocolModule components (all right -- a generic modu
le!)
*** Registering layout components
*** Registering nsGlobalHistoryModule components (all right -- a generic module!
)
*** Registering nsEudoraImportModule components (all right -- a generic module!)

*** Registering nsImportServiceModule components (all right -- a generic module!
)
*** Registering nsOEImport components (all right -- a generic module!)
*** Registering nsOutlookImport components (all right -- a generic module!)
*** Registering nsTextImportModule components (all right -- a generic module!)
*** Registering I18nCompatibility components (all right -- a generic module!)
*** Registering nsJarModule components (all right -- a generic module!)
*** Registering JS component loader components (all right -- a generic module!)
*** Registering javascript: protocol components (all right -- a generic module!)

*** Registering nsLWBrkModule components (all right -- a generic module!)
*** Registering nsMorkModule components (all right -- a generic module!)
*** Registering nsBrowserModule components (all right -- a generic module!)
nsFindComponent registration successful
nsUnknownContentTypeHandler registration successful
nsStreamTransfer registration successful
*** Registering nsMsgBaseModule components (all right -- a generic module!)
*** Registering nsMsgComposeModule components (all right -- a generic module!)
*** Registering nsMsgNewsModule components (all right -- a generic module!)
*** Registering nsCNativeAppModule components (all right -- a generic module!)
*** Registering necko core and primary protocols components (all right -- a gene
ric module!)
*** Registering necko secondary protocols components (all right -- a generic mod
ule!)
*** Registering nsGIFModule components (all right -- a generic module!)
*** Registering nsJPGModule components (all right -- a generic module!)
*** Registering nsPNGModule components (all right -- a generic module!)
*** Registering nsPrefMigrationModule components (all right -- a generic module!
)
*** Registering nsCJVMManagerModule components (all right -- a generic module!)
*** Registering nsProfileModule components (all right -- a generic module!)
*** Registering PSMComponent components (all right -- a generic module!)
*** Registering nsRDFModule components (all right -- a generic module!)
*** Registering nsRegistryViewerModule components (all right -- a generic module
!)
*** Registering nsRelatedLinksModule components (all right -- a generic module!)

*** Registering nsSampleModule components (all right -- a generic module!)
*** Registering nsSearchModule components (all right -- a generic module!)
*** Registering Session History Module components (all right -- a generic module
!)
*** Registering nsStringBundleModule components (all right -- a generic module!)

*** Registering nsTimeBomb components (all right -- a generic module!)
*** Registering nsTransactionManagerModule components (all right -- a generic mo
dule!)
*** Registering nsTextServicesModule components (all right -- a generic module!)

*** Registering UcharUtil components (all right -- a generic module!)
*** Registering uconv components
*** Registering nsUCvTWModule components (all right -- a generic module!)
RegSelf Unicode to Big5 converter complete
RegSelf Unicode to x-x-big5 converter complete
RegSelf Big5 to Unicode converter complete
*** Registering nsURILoaderModule components (all right -- a generic module!)
*** Registering Urlbar History Module components (all right -- a generic module!
)
*** Registering nsUrlWidget components (all right -- a generic module!)
*** Registering nsVCardModule components (all right -- a generic module!)
*** Registering nsWalletModule components (all right -- a generic module!)
*** Registering Browser Embedding Module components (all right -- a generic modu
le!)
*** Registering nsWindowsHooks components (all right -- a generic module!)
*** Registering nsWalletViewerModule components (all right -- a generic module!)

*** Registering xpconnect components (all right -- a generic module!)
*** Registering nsSoftwareUpdate components (all right -- a generic module!)
*** Registering nsPrefModule components (all right -- a generic module!)
nsNativeComponentLoader: autoregistering succeeded
*** Registering -chat handler.
*** Registering x-application-irc handler.
*** Registering irc protocol handler.
*** Deferring registration of sample JS components
************************************************************
** NOTE: This report will only be printed in DEBUG builds.**
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Factory not registered (may be tried again) [nsIModule::registerS
elf]"  nsresult: "0x80040155 (NS_ERROR_FACTORY_REGISTER_AGAIN)"  location: "<unk
nown>"  data: no]
************************************************************
*** Registering sample JS components
nNCL: registering deferred (0)
nNCL: registering deferred (0)
***** Chrome Registration: Installing package at resource:/chrome/packages/widge
t-toolkit/
***** Chrome Registration: Installing package at resource:/chrome/packages/core/

***** Chrome Registration: Installing locale at resource:/chrome/locales/en-US/
***** Chrome Registration: Installing package at resource:/chrome/packages/chatz
illa/
***** Chrome Registration: Installing locale at resource:/chrome/packages/chatzi
lla/
***** Chrome Registration: Installing skin at resource:/chrome/packages/chatzill
a/
***** Chrome Registration: Installing skin at resource:/chrome/skins/modern/
***** Chrome Registration: Installing skin at resource:/chrome/skins/classic/
***** Chrome Registration: Installing locale at resource:/chrome/locales/en-GB/
***** Chrome Registration: Installing package at resource:/chrome/packages/messe
nger/
ProfileName : default
ProfileDir  : D:\mozilla_src\mozilla\dist\WIN32_O.OBJ\bin\Users50\default
WEBSHELL+ = 1
plugins at: C:\Program Files\Netscape\Communicator\Program\Plugins
plugins at: D:\mozilla_src\mozilla\dist\WIN32_D.OBJ\bin\plugins
Initialized app shell component {18c2f989-b09f-11d2-bcde-00805f0e1353}, rv=0x000
00000
CSSLoaderImpl::LoadAgentSheet: Load of URL 'file:///D|/mozilla_src/mozilla/dist/
WIN32_O.OBJ/bin/Users50/default/chrome/user.css' failed.  Error code: 18
WEBSHELL+ = 2
Obtained name of Personal Toolbar from bookmarks string bundle.
Start reading in bookmarks.html
Finished reading in bookmarks.html  (250000 microseconds)
Enabling Quirk StyleSheet
Note: verifyreflow is disabled
Note: styleverifytree is disabled
Note: frameverifytree is disabled
Enabling Quirk StyleSheet

And that's where it hangs. A second launch of the debug build works properly, 
but loads the modern skin. In order to get the debug build to fail on startup 
like the optimized builds, I have to run an optimized build in between each 
running of the debug build.

Comment 3

18 years ago
This happens with default skin also.
(Reporter)

Comment 4

18 years ago
This is severely hindering any testing with Mozilla for me. Changing severity to 
reflect blockage of ability to test in any reasonable manner (per 
http://bugzilla.mozilla.org/bug_status.html#severity).
Severity: critical → blocker
(Reporter)

Comment 5

18 years ago
I just noticed that there is a splash screen, but it opens under all the other 
windows I have open. However, it just sits there displaying the splash screen.

Comment 6

18 years ago
What happens if you run it with -quiet?  Just wondering if it's at all related 
to the actual splash screen.
(Reporter)

Comment 7

18 years ago
It's the same. I noticed that if you reboot the computer you can run Mozilla 
once without deleting any files.
(Reporter)

Comment 8

18 years ago

*** This bug has been marked as a duplicate of 44342 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

16 years ago
Mass removing self from CC list.
(Reporter)

Comment 11

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.