Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: troy, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Nested object elements are not nesting like they should. Here's a small example:

<OBJECT data="test1.gif">
<OBJECT data="test2.gif">
</OBJECT>
</OBJECT>

Here's the dump of the content model:

html refcount=3<
  head refcount=2<
  >
  body refcount=3<
    object data=test1.gif refcount=4<
      Text refcount=2< \n>
    >
    object data=test2.gif refcount=4<
      Text refcount=2< \n>
    >
    Text refcount=3< \n \n>
  >
>

Comment 1

20 years ago
*** Bug 3692 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

20 years ago
Fixed by change to CNavDTD.
Test case from bug 3692 and bug 1945 shows this to be fixed, but I'll let
others mark verified.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 4

20 years ago
Verified 1999-16-17-08-M7
You need to log in before you can comment on or make changes to this bug.