email notifications when interface translation is on have no subject and generally suck

VERIFIED FIXED in 0.9.5

Status

VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: cilias, Assigned: ecooper)

Tracking

unspecified
0.9.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tiki_fixed)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
Created attachment 328509 [details]
eml file of notification

I got an email notification of an edit made to <http://support.mozilla.com/en-US/kb/Translating+the+interface>, and it looks very different from usual notifications.

* The Subject header is empty
* It contains a lot of markup in the page title and comment.

From what I can tell, it looks like a result of UI translation being on; but I could be wrong.
This might be an easy one to fix, but I'm not sure. Eric, I'm assigning it to you; please consult with Nelson if this is not straightforward. :)
Assignee: nobody → smirkingsisyphus
Target Milestone: --- → 0.8

Updated

10 years ago
Target Milestone: 0.8 → 0.9

Updated

10 years ago
Target Milestone: 0.9 → 1.0
(Assignee)

Comment 2

10 years ago
Chris was/is right. The problem was/is occurring in smarty when {tr} is called in the templates used for the notifications. The patch in r22889/r22890 makes sure to turn of UI translation while emails are being sent (and turn it back on after it's done if necessary). 

STR (requires two accounts to test):

1. Have Account A watch any wiki page or forum topic.
2. Log out of Account A and into Account B.
3. Turn on UI translation under "Contributors Tools" on the right for Account B
4. Edit the wiki page or post in the forum topic Account A is watching

Expected:
Well-formed email notification is sent to email addy for Account A

Actual:
Comment 1
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Created attachment 365830 [details]
My test email, post-fix
(In reply to comment #3)
> Created an attachment (id=365830) [details]
> My test email, post-fix

^^^ Chris, that's fixed, right?
Created attachment 365841 [details]
Screenshot comparing the two

Fixed is obviously on the left; broken on the right.
Verified FIXED; once the beer wore off, comment 5 was easy to see :-)
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

10 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > Created an attachment (id=365830) [details] [details]
> > My test email, post-fix
> 
> ^^^ Chris, that's fixed, right?

As long as the interface translator was on at the time of the edit, yes.
I'm so glad this is going to be fixed in the next push.
Whiteboard: tiki_bug
The side effect caused by interactive translation is no longer an issue since I reworked it (was broken).
Whiteboard: tiki_bug → tiki_bug, tiki_fixed
Whiteboard: tiki_bug, tiki_fixed → tiki_fixed
You need to log in before you can comment on or make changes to this bug.