Closed Bug 444133 Opened 12 years ago Closed 12 years ago

Reloading a file:/// URL does not always work if the file was replaced

Categories

(Firefox :: File Handling, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 322686

People

(Reporter: gboyce, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9) Gecko/2008061004 Firefox/3.0

When I work on creating an html document on my local system, I generally bring it up within Firefox using a file:///path/to/file.html url, and then reload it as I make changes.

After the release of Firefox 3, I found a new quirk in the behavior when I work like this.  If I save changes to the file and hit reload, the file does not fails to load.  It does not happen consistently, but once it does occur, the only way to recover is to enter the location bar and hit enter.

--------

The error I get when I hit reload is:

File Not Found
          
Firefox can't find the file at /Users/gboyce/test.html.

    * Could the item have been renamed, removed, or relocated?
    * Is there a spelling, capitalization, or other typographical error in the address?
    * Do you have sufficient access permissions to the requested item?

--------

Note that I am editing the file in vim.  when vim saves a file, it saves to a temporary file, and then moves it into place, removing the old existing file.  Perhaps firefox is holding onto an old file handle for the now deleted version rather than looking it up on disk again?

Reproducible: Sometimes

Steps to Reproduce:
1. Create file called test.html, insert content
2. Load file into Firefox using a file:///path/to/test.html url
3. edit the file in vim, and save using :w
4. Hit reload in Firefox

Actual Results:  
File not found error

Expected Results:  
The file should update.

This is Mac OS X 10.4, using Filevault.
Firefox 3.0 with the noscript plugin installed.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322686
You need to log in before you can comment on or make changes to this bug.