Weave sync fails with "Could not acquire lock" in log (sometimes with 'status 423' or 'status 503')

RESOLVED FIXED

Status

Cloud Services
General
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 328529 [details]
snippets from verbose log (separated by blank lines)

Weave currently isn't syncing for me.  Each time I try to sync, the weave icon spins for maybe 30 sec - 1 min, and then stops spinning. (as if everything were ok -- but it's not)

When I examine the logs, I see a variety of error messages about "Could not acquire lock". I'm attaching a text file with snippets of these errors from my verbose log.

I've tried the "Reset Server Lock" option several times, and that doesn't fix the issue.

This happens on each of the 3 machines I use with this Weave account.

VERSION INFO: (same on all 3 machines)
 * Weave 0.2.0
 * Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
 * Ubuntu Linux 8.04
Hardware / OS --> All/All, per sheedatali mentioning the same locking issues on Mac OS X here:
https://labs.mozilla.com/forum/index.php/topic,1170.msg4719.html#msg4719
OS: Linux → All
Hardware: PC → All
This has now started working for me.

I'm guessing it's working because the Labs team wiped the lock database this morning. (mentioned in #labs at around 11:20am PST today)

Leaving bug open for now, pending other people possibly still having this issue / the issue resurfacing, because AFAIK whatever code caused this bug in the first place probably hasn't changed...

Comment 3

10 years ago
I'm still having this issue since the 0.2.2 update, and have tried the reset server lock option as well.  Her's from my activity log:

2008-07-09 08:16:17   Chrome.Window   INFO   Logging in...
2008-07-09 08:16:17   Chrome.Window   INFO   User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 08:16:17   Chrome.Window   INFO   Weave version: 0.2.2
2008-07-09 08:16:18   Service.Main   INFO   Using server URL: https://services.mozilla.com/user/******/
2008-07-09 08:16:21   Service.Main   INFO   Fetching keypair from server.
2008-07-09 08:16:23   Service.Main   INFO   Weave scheduler enabled
2008-07-09 08:16:23   Chrome.Window   INFO   Login successful
2008-07-09 08:16:24   Service.DAV   WARN   _makeRequest: got status 423
2008-07-09 08:16:24   Async.Generator   ERROR   Exception: Could not acquire lock
2008-07-09 08:19:32   Service.DAV   WARN   _makeRequest: got status 423
2008-07-09 08:19:32   Async.Generator   ERROR   Exception: Could not acquire lock
2008-07-09 08:19:37   Async.Generator   ERROR   Exception: Could not acquire lock (lock already held)
2008-07-09 08:19:38   Service.DAV   WARN   _makeRequest: got status 423
2008-07-09 08:19:38   Async.Generator   ERROR   Exception: Could not acquire lock
2008-07-09 08:19:41   Service.DAV   WARN   _makeRequest: got status 423
2008-07-09 08:19:41   Async.Generator   ERROR   Exception: Could not acquire lock
2008-07-09 08:19:51   Service.DAV   WARN   _makeRequest: got status 423
2008-07-09 08:19:51   Async.Generator   ERROR   Exception: Could not acquire lock
2008-07-09 08:21:23   Service.Main   INFO   Running scheduled sync
2008-07-09 08:21:25   Service.DAV   WARN   _makeRequest: got status 423
2008-07-09 08:21:25   Async.Generator   ERROR   Exception: Could not acquire lock
Michael - have you tried syncing since noonish (pacific time) today?  That's when the lock database was reset, per comment 2, and AFAIK that should temporarily fix the issue (for the time being, until the real root cause is discovered).

Comment 5

9 years ago
Weave no longer uses WebDAV, and no longer needs to lock the server while syncing.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.