No easy way to return focus to content area from location bar or search bar

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: zachary, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

If the location bar or the search bar has focus, there is no easy way (using the keyboard) of returning focus to the main browser pane.  The only way I can think of is to hit control-shift-F6, but even this is not ideal, since it won't return focus to the exact place you had originally (e.g., if you were in the middle of editing a text box).

My suggestion is to have "Esc" return the focus, and perhaps have a dedicated keyboard shortcut as well.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://www.google.com
2. Type a few letters into the input box on the page
3. Hit control-L
4. Hit "Esc"
5. Hit control-shift-F6
6. Type a few more letters
Actual Results:  
After step 4, nothing happens.
After step 5, a dotted line appears around the entire tab pane.
After step 6, Quick Find bar pops up, and new text is not added to input box on the page.

Expected Results:  
After step 4 (and step 5), focus should return to the input box on the page.
After step 6, new letters typed should be appended to the text already in the input box.

Updated

11 years ago
Summary: No easy way to return focus to main window from location bar or search bar → No easy way to return focus to content area from location bar or search bar

Comment 1

10 years ago
Well, you can hit tab multiple times to get back to where you want to be/where you were. Not ideal obviously (I like the Esc idea), but you can get back to the main browser pane through keyboard alone.

Comment 2

8 years ago
This works in Firefox 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.