If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Example Wikipedia link causes instant crash of FF3

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Jason Quinn, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: INVALID?)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0

An instant crash example caused by clicking on a link in Wikipedia.

Reproducible: Always

Steps to Reproduce:
1. Go to this Wikipedia page:
http://en.wikipedia.org/wiki/Wikipedia:Typo

2. Find the "See Wikipedia:Typo/Members" link.

3. Clicking on that link causes an instant crash.
Actual Results:  
Crash.

Expected Results:  
No crash.
No crash on Windows (and Firefox 3).
Please enter about:crashes as URl and provide a crash ID of this crash if you submitted a Mozilla crash report

wfm with FF3.0 on win32 but i my SM got closed once by windows DEP but I can not reproduce this.

Comment 3

9 years ago
Are you using Debian GNU/Linux lenny/sid? Do any other applications (like editors) crash when trying to display the file?

If so, see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=488015 and its duplicates: you probably need to update the libpango packages to 1.20.4-1.

Updated

9 years ago
Keywords: crash
Whiteboard: INVALID?
I'm using the same buildid Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0, and I don't see this crash.

This problem could be from an extension, or out of date libraries as Aleksej suggested. You will likely get an answer faster at http://support.mozilla.com - see http://support.mozilla.com/en-US/kb/Basic+Troubleshooting for a good starting place there, and work from there. If it still turns out to be a bug after troubleshooting, then you can come back here and we'll reopen your bug.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

9 years ago
I tried again today and no crash. Grrrrr. I yesterday I restarted the browser and all and yet it still caused a crash; but today, nothing. I use no extensions. I thought maybe it was flash running in another tab that might have caused it but nope. Now I have no idea what it might have been.

Comment 6

9 years ago
No crash. Ubuntu Linux 8.04, Firefox 3.0, Adblock Plus, Firebug, Snapshot.
You need to log in before you can comment on or make changes to this bug.