Weave should not interfere in add-on or application updates

RESOLVED FIXED

Status

Cloud Services
General
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: stazybohorn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008070603 Minefield/3.1a1pre (like Firefox/3.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008070603 Minefield/3.1a1pre (like Firefox/3.0) ID:2008070603

Whenever Fx restarts due to an xpi /theme install, or an update to an extension /theme or even the application itself, weave should not perform as in normal application exit and launch (or, at least, there should be a preference setting fot this); it's just a waste of time.

Reproducible: Always

Actual Results:  
Long delays

Expected Results:  
immediate firefox restart

Updated

9 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 1

9 years ago
patch applied to trunk to skip sync on quit when there is a forced restart
http://hg.mozilla.org/labs/weave/index.cgi/diff/389d9ff46d61/modules/service.js
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.