Per-forum-post "problem solved" status

VERIFIED FIXED in 0.8

Status

support.mozilla.org
Forum
P1
normal
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: djst, Assigned: ecooper)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only)

Attachments

(7 attachments)

(Reporter)

Description

10 years ago
Currently a whole thread can be marked as solved, which gives us the ability to see which threads have been solved and which haven't. However, we lack the ability to say "post x solved this thread," which would give us a lot of possible benefits:

* Ability to visually highlight the solution to a thread
* Link at the top of a thread saying "Skip to the solution to this problem"
* Contributor karma - ability to tell how many problems a helper has solved

This likely requires some DB changes to include the user stats, the forum post status, etc.

Updated

9 years ago
Target Milestone: 0.7 → 0.8

Updated

9 years ago
Assignee: nobody → smirkingsisyphus
Priority: -- → P1
(Assignee)

Comment 1

9 years ago
This bug is to just allow to mark per-post solutions, right? 

This is already partially implemented when op/admins mark a thread as being solved by clicking "yes" to the "Did this post resolve your problem?" question.
(Reporter)

Comment 2

9 years ago
Do we have UI that allows the OP to go back to a thread and pick among the responses which one solved the problem? 

I mean if the OP didn't already click yes from the email notification.
(Assignee)

Comment 3

9 years ago
Created attachment 351608 [details]
Proposed UI change for marking solutions

Yes and no. The patch coming will make sure the CSAT and setting solutions are mostly a separate process.

In any case, op/admins will be able to set a single solution to the thread, which brings me to a question. Currently, the "Did this post resolve your problem? [Yes]" prompt is used. I'm not a big fan of it and have been exploring other possibilities. Could we use something like this (to initiate the CSAT and to mark solutions)?
(Assignee)

Comment 4

9 years ago
Created attachment 351920 [details] [diff] [review]
Makes sure posts are marked as 'o' when thread is solved.

This patch keeps the "Did this post resolve your problem?" UI and makes sure it remains displayed to op/admins until a thread has a solution.

Marked posts are also given the 'o' status type.
Attachment #351920 - Flags: review?
(Assignee)

Updated

9 years ago
Attachment #351920 - Flags: review? → review?(nelson)

Comment 5

9 years ago
Comment on attachment 351920 [details] [diff] [review]
Makes sure posts are marked as 'o' when thread is solved.

in r20607/r20608
Attachment #351920 - Flags: review?(nelson) → review+

Comment 6

9 years ago
When I tested this as an admin, the "Did this post resolve your problem?" UI showed even after the thread has a solution, and then I can then choose a different post this time, which then seemed to take effect.

Is this by design, and if so, does making multiple choices mess up anything?

I also did not try as OP. How does it work for the OP?
(Assignee)

Comment 7

9 years ago
It actually just makes sure a particular thread has a solution post associated with it (via the reported posts table). So, the thread can be marked solved, but if a solution can't be found, you can pick one still.

Ops see the same thing.

Comment 8

9 years ago
Created attachment 352117 [details] [diff] [review]
Set thread_has_solution flag correctly

Updated

9 years ago
Attachment #352117 - Flags: review?(laura)

Updated

9 years ago
Attachment #352117 - Flags: review?(laura) → review+
(Reporter)

Comment 9

9 years ago
(In reply to comment #3)
> In any case, op/admins will be able to set a single solution to the thread,
> which brings me to a question. Currently, the "Did this post resolve your
> problem? [Yes]" prompt is used. I'm not a big fan of it and have been exploring
> other possibilities. 

Are you talking about the e-mail notification link? The reason why we need that is because many people never find their way back to the thread they posted, and an email notification makes sure they get the response. What are you not a big fan of?

> Could we use something like this (to initiate the CSAT and
> to mark solutions)?

If we can identify the OP (meaning he/she is logged in, or he/she clicked a link in the e-mail notification taking him/her back to the thread posted), then the UI you propose works well, although I'd rather put the text on the same line as the posted date, and I'd make it shorter, e.g.: "This answer solved my problem." We should also add a small icon to the left of it (e.g. a thumbs up, or a green tick or something), but that's not required here.
(Reporter)

Comment 10

9 years ago
Oops, mid-aired there. 

So, mainly this UI you propose in https://bugzilla.mozilla.org/attachment.cgi?id=351920 would be used by moderators, but also for registered users or anonymous posters that we managed to identify as the original poster because they clicked a hashed link back to the forum thread.

Comment 11

9 years ago
Comment on attachment 352117 [details] [diff] [review]
Set thread_has_solution flag correctly

in r20619/r20620

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 12

9 years ago
reopened to handle some of the UI comments
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 13

9 years ago
I also mentioned on irc that the text is smaller than the date. Since we're moving it up to the same line, can we also use the same size?
(Assignee)

Comment 14

9 years ago
Created attachment 352136 [details]
UI moved up to "date line", made blue, no button

How's this looking?
(Assignee)

Updated

9 years ago
Attachment #352136 - Attachment is patch: false
Attachment #352136 - Attachment mime type: text/plain → image/png
(Reporter)

Comment 15

9 years ago
Looks good to me! :)
(Assignee)

Comment 16

9 years ago
Created attachment 352155 [details] [diff] [review]
Gets rid of the old UI and put the new one in the same area as the date
Attachment #352155 - Flags: review?(nelson)

Comment 17

9 years ago
Comment on attachment 352155 [details] [diff] [review]
Gets rid of the old UI and put the new one in the same area as the date

in r20666/r20667
Attachment #352155 - Flags: review?(nelson) → review+

Updated

9 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Created attachment 352262 [details]
Screenshot, post-fix, showing new text for two responses
Created attachment 352263 [details]
2nd Screenshot, post-fix, showing "Whatever." post fixed it, with ratings
Would love it for David or others to chime in on this fix, but I'm pretty sure it's ready to be verified.
(Reporter)

Comment 21

9 years ago
I love this fix and I love this community!!
Status: RESOLVED → VERIFIED
So awesome.
(Reporter)

Updated

8 years ago
Whiteboard: tiki_feature
Whiteboard: tiki_feature → tiki_feature, tiki_depend
Whiteboard: tiki_feature, tiki_depend → sumo_only
You need to log in before you can comment on or make changes to this bug.