Closed Bug 444360 Opened 12 years ago Closed 8 years ago

Cookie/Password engines should also sync cookie/password permissions

Categories

(Firefox :: Sync, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 470699
Future

People

(Reporter: jk, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0 eMusic DLM/4.0_1.0.0.1
Build Identifier: 0.2.2

Syncing cookies without syncing cookie permissions (no/yes/session-only) for sites is a bit useless, especially for users who don't allow cookies for any site by default: A cookie for a white-listed site gets synced but the white-list entry for the site doesn't.
The same applies to passwords and password permissions.

Please consider syncing permissions.sqlite too.

Reproducible: Always
Justin, just FYI.  Let's talk on monday maybe?
To clarify: this is a request to sync the password and cookie per-site prefs that control whether to ask the user what to do (e.g. pop down the infobar and ask to save the password).  Similar to site-specific prefs.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Target Milestone: -- → Future
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
Blocks: 530399
Component: General → Sync
QA Contact: general → sync
Duplicate of this bug: 579314
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9)
> Gecko/2008052912 Firefox/3.0 eMusic DLM/4.0_1.0.0.1
> Build Identifier: 0.2.2
> 
> Syncing cookies without syncing cookie permissions (no/yes/session-only) for
> sites is a bit useless, especially for users who don't allow cookies for any
> site by default: A cookie for a white-listed site gets synced but the
> white-list entry for the site doesn't.
> The same applies to passwords and password permissions.
> 
> Please consider syncing permissions.sqlite too.
> 
> Reproducible: Always

To clarify: Cookie and Password "Exceptions" are not being synced. This is the issue I see as the problem which I would like to see resolved.
I should note that Sync does not currently sync cookies; see Bug 638865.
Duplicate of this bug: 706409
Is this the same as bug 470699? Is everything consolidated in the permissions manager backend or is it just the frontend that is consolidated in about:permissions?
It is now, indeed.  Cookie perms used to be special, but no longer.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470699
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.