Table spacing calculation error when repeatedly displaying/hiding

RESOLVED DUPLICATE of bug 435189

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 435189
10 years ago
9 years ago

People

(Reporter: Tom Oldbury, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008061015 Firefox/3.0

The spacing on a table seems to get messed up between two parts of a table. If you have one part which is constantly shown (a header) and parts which are revealed using JavaScript (and can also be hidden), when you trigger the JavaScript to hide and then show it, there seems to be a single pixel error. This builds up as you repeat the action. 

Reproducible: Always

Steps to Reproduce:
1. Load the attachment supplied. 
2. Click [Show] to reveal cells. 
3. Click [Hide] to hide.
4. Repeat as necessary, note the spacing after several actions. 
Actual Results:  
There was some kind of spacing when there shouldn't have been.

Expected Results:  
No spacing.
(Reporter)

Comment 1

10 years ago
Created attachment 328701 [details]
Testcase

HTML testcase with JavaScript and some CSS to make error visible.
(Reporter)

Comment 2

10 years ago
Created attachment 328702 [details]
Testcase (with strict doctype & red table) - more visible

A more visible version.
Attachment #328701 - Attachment is obsolete: true

Comment 3

9 years ago
Thanks for reporting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 435189
You need to log in before you can comment on or make changes to this bug.