Ability to localize modules

RESOLVED FIXED in 1.0.2

Status

support.mozilla.org
Localization
--
major
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: cilias, Assigned: ecooper)

Tracking

unspecified
1.0.2

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tiki_fixed)

(Reporter)

Description

10 years ago
Modules on the sidebar should be localizable.

Updated

10 years ago
Target Milestone: --- → Future
(Reporter)

Updated

9 years ago
Duplicate of this bug: 476801
(Reporter)

Comment 2

9 years ago
Moving to 1.0.
The inproduct start page which gets around 70% of total website traffic contains a module ("Improving the KB"), and we'd like to make the start page fully localizable for SUMO 1.0.
Target Milestone: Future → 1.0

Updated

9 years ago
Assignee: nobody → laura
(Reporter)

Comment 3

9 years ago
FWIW, here's the URL of the admin interface: <https://support-stage.mozilla.org/tiki-admin_modules.php>.

Updated

9 years ago
Target Milestone: 1.0 → 1.1

Updated

9 years ago
Target Milestone: 1.1 → 1.0

Updated

9 years ago
Target Milestone: 1.0 → 1.0.2

Comment 4

9 years ago
We discussed in a sumo development meeting two possibilities:

1) translation tags can just be added around the content of the start page module, making it localizeable - ecooper would check if this is true

2) if the above doesn't work, we move the front page box out of the module and just put it directly in the template
Assignee: laura → smirkingsisyphus
(Assignee)

Comment 5

9 years ago
(In reply to comment #4)
> We discussed in a sumo development meeting two possibilities:
> 
> 1) translation tags can just be added around the content of the start page
> module, making it localizeable - ecooper would check if this is true
> 
> 2) if the above doesn't work, we move the front page box out of the module and
> just put it directly in the template

Smarty {tr} blocks can be used in modules just as they're used in templates. As per comment 2, I added tr blocks to the "improve" module on staging for testing. You can now use the interactive translation feature to localize the text.

For reference: https://support-stage.mozilla.org/tiki-admin_modules.php?um_edit=improve#editcreate
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
Are you kidding me? Has this been possible this whole time? :-)
(Reporter)

Comment 7

9 years ago
I've done this for the Thunderbird block as well, because . I'll send an invite for locale leaders to test this on staging.
(Reporter)

Comment 8

9 years ago
(In reply to comment #7)
> I've done this for the Thunderbird block as well, because 

because I clicked [Commit] to soon. Those two blocks appear on navigation pages, and are what locale leaders have been most vocal about.
I don't know if this is happening just to me, but the Thunderbird module content "Looking for Thunderbird support?" is not getting translated...

Comment 10

9 years ago
Yes, I can confirm: it is not possible to translate "Looking for Thunderbird support?" (only).

Comment 11

9 years ago
(In reply to comment #9)
> I don't know if this is happening just to me, but the Thunderbird module
> content "Looking for Thunderbird support?" is not getting translated...

Confirmed too.
I experience some problems, I don't know if temporaly, translating these links:
Learn more... and Find out how you can help.
(Reporter)

Comment 12

9 years ago
It must be the line break. The source looks like this:
{tr}Looking for Thunderbird<br />support?{/tr}

I've changed it to:
{tr}Looking for Thunderbird{/tr}<br />{tr}support?{/tr}

This will turn it into 2 separate strings.
(Reporter)

Comment 13

9 years ago
Actually, do we even need the "<br />" in "Looking for Thunderbird<br />support?"
Sounds like the proper fix would be to make sure that the margins are set properly so the text doesn't span across the Thunderbird logo. Adding a <br> seems like a dirty solution.
(Reporter)

Comment 15

9 years ago
(In reply to comment #14)
> Sounds like the proper fix would be to make sure that the margins are set
> properly so the text doesn't span across the Thunderbird logo. Adding a <br>
> seems like a dirty solution.

Filed bug 492585.
(Reporter)

Comment 16

9 years ago
"Thunderbird" and "Improve the Knowledge Base" are now localizable on support.mozilla.com. I'll apply this to the rest later.

Updated

8 years ago
Whiteboard: tiki_fixed
You need to log in before you can comment on or make changes to this bug.