Firefox 3.1a1pre nightly crashes when typing msn in location bar and pressing enter

RESOLVED DUPLICATE of bug 421217

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 421217
10 years ago
10 years ago

People

(Reporter: Joseph W Becher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008070903 Minefield/3.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008070903 Minefield/3.1a1pre

Firefox 3.1a1pre nightly crashes when typing msn in location bar and pressing enter. This happens with nealy all addons disabled, including greasemonkey.

Reproducible: Always

Steps to Reproduce:
1. Install 3.1 Nightly
2. Type msn in location bar
3. Press enter
Actual Results:  
Breakpad loads with crash

Expected Results:  
Page loads

08fa518c-4dcd-11dd-84f2-001a4bd43e5c	7/9/2008	11:38 AM
f6899ab0-4dcb-11dd-94f2-001a4bd43ed6	7/9/2008	11:30 AM
d1d3ac7d-4dcb-11dd-8cf9-001a4bd43ef6	7/9/2008	11:29 AM
bbe81561-4dcb-11dd-afc9-001cc45a2ce4	7/9/2008	11:28 AM
47f2cf6e-4dc9-11dd-b664-001a4bd43ef6	7/9/2008	11:11 AM
20c3f80a-4dc9-11dd-96be-001a4bd43ef6	7/9/2008	11:10 AM
0c9b2d61-4dc9-11dd-aa8a-001cc45a2ce4	7/9/2008	11:09 AM
f2372d7a-4dc8-11dd-8494-001321b13766	7/9/2008	11:08 AM

# Operating system: Windows NT
#                   5.1.2600 Service Pack 3
# CPU: x86
#      AuthenticAMD family 6 model 6 stepping 2
#      1 CPU
#  
# Crash reason:  EXCEPTION_ACCESS_VIOLATION
# Crash address: 0x10
#  
# Thread 0 (crashed)
#  0  js3250.dll + 0x469fb
#     eip = 0x003369fb   esp = 0x0012fb04   ebp = 0x00000000   ebx = 0x0012fb78
#     esi = 0x0017e028   edi = 0x043e1340   eax = 0x00000001   ecx = 0x00000000
#     edx = 0x0795000c   efl = 0x00210202
#
(Reporter)

Comment 1

10 years ago
Created attachment 328768 [details]
Manually parsed breakpad dump because the site is lagged
a binary dump doesn't help, you must wait for the server to process the crash IDs or create a stack with Windbg
(Reporter)

Comment 4

10 years ago
http://crash-stats.mozilla.com/report/index/47f2cf6e-4dc9-11dd-b664-001a4bd43ef6
 has cleared, also I have the following, is this what you needed?


1:002> g
ModLoad: 629c0000 629c9000   C:\WINDOWS\system32\LPK.DLL
ModLoad: 59a60000 59b01000   C:\WINDOWS\system32\dbghelp.dll
ModLoad: 74720000 7476c000   C:\WINDOWS\system32\MSCTF.dll
ModLoad: 77920000 77a13000   C:\WINDOWS\system32\SETUPAPI.dll
ModLoad: 755c0000 755ee000   C:\WINDOWS\system32\msctfime.ime
ModLoad: 76fd0000 7704f000   C:\WINDOWS\system32\CLBCATQ.DLL
ModLoad: 77050000 77115000   C:\WINDOWS\system32\COMRes.dll
ModLoad: 71a50000 71a8f000   C:\WINDOWS\system32\mswsock.dll
ModLoad: 662b0000 66308000   C:\WINDOWS\system32\hnetcfg.dll
ModLoad: 71a90000 71a98000   C:\WINDOWS\System32\wshtcpip.dll
ModLoad: 76d60000 76d79000   C:\WINDOWS\system32\iphlpapi.dll
ModLoad: 00eb0000 00eb8000   G:\Program Files\Mozilla Firefox\components\browserdirprovider.dll
ModLoad: 00ec0000 00ee3000   G:\Program Files\Mozilla Firefox\components\brwsrcmp.dll
ModLoad: 5ad70000 5ada8000   C:\WINDOWS\system32\uxtheme.dll
ModLoad: 76f20000 76f47000   C:\WINDOWS\system32\DNSAPI.dll
ModLoad: 76fb0000 76fb8000   C:\WINDOWS\System32\winrnr.dll
ModLoad: 76f60000 76f8c000   C:\WINDOWS\system32\WLDAP32.dll
ModLoad: 16080000 16099000   C:\Program Files\Bonjour\mdnsNSP.dll
ModLoad: 01c00000 01ec5000   C:\WINDOWS\system32\xpsp2res.dll
ModLoad: 01520000 01545000   G:\Program Files\Mozilla Firefox\softokn3.dll
ModLoad: 01550000 01568000   G:\Program Files\Mozilla Firefox\nssdbm3.dll
ModLoad: 01570000 015a9000   G:\Program Files\Mozilla Firefox\freebl3.dll
ModLoad: 015b0000 015f9000   G:\Program Files\Mozilla Firefox\nssckbi.dll
ModLoad: 76fc0000 76fc6000   C:\WINDOWS\system32\rasadhlp.dll
ModLoad: 029a0000 029b2000   G:\Program Files\Mozilla Firefox\plugins\npnul32.dll
ModLoad: 6cd00000 6cdb2000   C:\Program Files\Microsoft Silverlight\2.0.30226.2\npctrl.1.0.30401.0.dll
ModLoad: 6c900000 6cbbc000   C:\Program Files\Microsoft Silverlight\2.0.30226.2\agcore.dll
ModLoad: 78050000 78120000   C:\WINDOWS\system32\WININET.dll
ModLoad: 029e0000 029e9000   C:\WINDOWS\system32\Normaliz.dll
ModLoad: 7f560000 7f68e000   C:\WINDOWS\system32\urlmon.dll
ModLoad: 5dca0000 5dce5000   C:\WINDOWS\system32\iertutil.dll
ModLoad: 77270000 77296000   C:\WINDOWS\system32\IESetting.dll
ModLoad: 73f10000 73f6c000   C:\WINDOWS\system32\DSOUND.dll
ModLoad: 74c80000 74cac000   C:\WINDOWS\system32\OLEACC.dll
ModLoad: 76080000 760e5000   C:\WINDOWS\system32\MSVCP60.dll
ModLoad: 77a80000 77b15000   C:\WINDOWS\system32\CRYPT32.dll
ModLoad: 77b20000 77b32000   C:\WINDOWS\system32\MSASN1.dll
(3c8.e2c): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00000001 ebx=0012fb78 ecx=00000000 edx=00150608 esi=00188c28 edi=02b6a990
eip=0033671b esp=0012fb04 ebp=00000010 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00210202
*** WARNING: Unable to verify checksum for G:\Program Files\Mozilla Firefox\js3250.dll
js3250!JS_SetPrivate+0xb:
0033671b 894110          mov     dword ptr [ecx+10h],eax ds:0023:00000010=????????
1:002> kp
*** WARNING: Unable to verify checksum for G:\Program Files\Mozilla Firefox\xul.dll
ChildEBP RetAddr  
0012fb00 1031ea7f js3250!JS_SetPrivate(struct JSContext * cx = <Memory access error>, struct JSObject * obj = <Memory access error>, void * data = <Memory access error>)+0xb [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\js\src\jsapi.cpp @ 2888]
0012fb1c 100d683d xul!NPObjWrapperPluginDestroyedCallback(struct PLDHashTable * table = <Memory access error>, struct PLDHashEntryHdr * hdr = <Memory access error>, unsigned int number = <Memory access error>, void * arg = <Memory access error>)+0x4e [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\modules\plugin\base\src\nsjsnpruntime.cpp @ 1805]
0012fb4c 1060ceab xul!PL_DHashTableEnumerate(struct PLDHashTable * table = <Memory access error>, <function> * etor = <Memory access error>, void * arg = <Memory access error>)+0x7d [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\obj-firefox\xpcom\build\pldhash.c @ 724]
0012fbb8 10641a6e xul!nsJSNPRuntime::OnPluginDestroy(struct _NPP * npp = 0x0066c058)+0x9f [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\modules\plugin\base\src\nsjsnpruntime.cpp @ 1846]
0012fc04 10612e80 xul!ns4xPluginInstance::Stop(void)+0x18f [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\modules\plugin\base\src\ns4xplugininstance.cpp @ 960]
0012fc30 10623cf9 xul!DoStopPlugin(class nsPluginInstanceOwner * aInstanceOwner = 0x0066c040, int aDelayedStop = 0)+0xf9 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\layout\generic\nsobjectframe.cpp @ 1828]
0012fc64 100f7838 xul!nsStopPluginRunnable::Run(void)+0x29 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\layout\generic\nsobjectframe.cpp @ 1890]
0012fc88 1010820a xul!nsThread::ProcessNextEvent(int mayWait = <Memory access error>, int * result = <Memory access error>)+0x218 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\xpcom\threads\nsthread.cpp @ 511]
0012fca0 101a21cd xul!nsBaseAppShell::Run(void)+0x4a [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\widget\src\xpwidgets\nsbaseappshell.cpp @ 169]
0012fcac 100506f6 xul!nsAppStartup::Run(void)+0x1e [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\toolkit\components\startup\src\nsappstartup.cpp @ 182]
0012fcb4 006220a8 xul!XRE_main(int argc = 277073512, char ** argv = 0x00000000, struct nsXREAppData * aAppData = 0x04a2c970)+0xdb0 [e:\builds\moz2_slave\mozilla-central-win32-nightly\build\toolkit\xre\nsapprunner.cpp @ 3174]
WARNING: Frame IP not in any known module. Following frames may be wrong.
0012fcb8 00000000 0x6220a8
This is from Breakpad :

0  	js3250.dll  	JS_SetPrivate  	 js/src/jsapi.cpp:2918
1 	xul.dll 	NPObjWrapperPluginDestroyedCallback 	modules/plugin/base/src/nsJSNPRuntime.cpp:1805
2 	xul.dll 	xul.dll@0x8df08b

You are using a beta plugin that is well known broken, Silverlight.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 421217
(Reporter)

Comment 6

10 years ago
Confirmed. Uninstalled Silverlight, used IE to download latest version and install, issue resolved. Thanks for the help.
You need to log in before you can comment on or make changes to this bug.