Closed Bug 444472 Opened 12 years ago Closed 12 years ago

Prism Refractor (v0.2) breaks firefox 3.0 on Ubuntu 8.04

Categories

(Mozilla Labs :: Prism, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: twentyafterfour+bz, Assigned: matthew.gertner)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008052912 Firefox/3.0

A couple of people have reported this by posting "reviews" on AMO. I am just filing a formal bug report since it doesn't seem to be in bugzilla. Note that I am able to reproduce this issue and there are at least two other reports, in all cases it seems to be related to Firefox 3.0 on Ubuntu.

Here is one of the "reviews" posted on the AMO page for Refractor: 

"Causes Firefox to close after file download

    I installed this extension. Then every time I downloaded a file from the internet and saved it, Firefox would close. I desabled the extension and the problem disappeared. Hope this issue will be corrected soon, as like the extension."

Reproducible: Always

Steps to Reproduce:
1. Install Refractor 0.2 into the default Firefox that is included with Ubuntu v8.04 (In my case all ubuntu updates have been applied) 
2. Restart firefox so that Refractor is enabled.
3. Download any file that triggers the firefox download manager (e.g. this link: http://people.mozilla.com/~mfinkle/prism/prism-0.9.en-US.linux-i686.tar.bz2) 
Actual Results:  
Firefox exits or crashes. It doesn't trigger crash report dialog, The firefox process just disappears without a trace. I don't think Ubuntu enables the mozilla crash reporter so it may just be a silent crash, I can't quite tell.

Expected Results:  
Firefox does not exit / crash.

Note: This may actually be a bug in the way that Ubuntu has packaged Firefox.

A couple of "reviews" on AMO are reporting the same behavior, and it seems like it's definitely related to ubuntu's firefox - the crash does not happen with a Firefox binary that I downloaded directly from Mozilla.

I'm not sure whether this is a bug in ubuntu or the refractor extension but I suspect that both may need patching - it's only the combination of refractor+ubuntu that triggers this bug.

I'll try to post a bug report in ubuntu's launchpad so that the maintainers are aware of the issue. It's really strange that it only happens with the distro's firefox and not with the untouched mozilla release of the same code. Since ubuntu includes a branded "Firefox" they are presumably limited to very basic changes that won't break Firefox.
I was told by asac in #ubuntu-mozillateam that I should try updating to some "proposed" packages for libnspr / libnss... This didn't work because of dependency problems in the packages. however, I'll test once that's fixed too see if it resolves the issue with Prism.
We appear to be adding a global listener to the download manager which we don't need. As a result, it tries to install every file that gets downloaded. Obviously this is bad (and not just on Ubuntu, even if it doesn't crash elsewhere).
Assignee: nobody → matthew.gertner
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #328855 - Flags: review?(mark.finkle)
Attachment #328855 - Flags: review?(mark.finkle) → review+
I could have sworn there was a check to make sure the content-type matched correctly before the file was downloaded. Otherwise it should have tried to launch Prism on every file download.

The code has been checked in: r16886. Mukunda can you verify that it works properly now?
How do I test the svn version? I can't figure out how to build a usable extension from the svn checkout... ;(
(In reply to comment #5)
> How do I test the svn version? I can't figure out how to build a usable
> extension from the svn checkout... ;(
> 
It might be in this build:
http://browsing.justdiscourse.com/2008/07/10/mozilla-prism-091-experimental-now-available/
Confirmed - bug is fixed in SVN....

No that build didn't have it but I was able to patch it from the svn (Thankfully that was an unpacked build so it wasn't difficult to update)


Thanks everyone for getting this one fixed to quickly (this goes for the ubuntu mozilla team as well!)

It wasn't effecting me that much but I hate to see Linux get second-class treatment and that definitely didn't happen here.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.