Bookmarks > Organise Bookmarks > Backup = 0 byte .json file

RESOLVED DUPLICATE of bug 458683

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 458683
10 years ago
9 years ago

People

(Reporter: ro9u3b46, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0

Every option that I have for backing up my bookmarks creates a 0 byte file. When I add a bookmark the resultant backup .json file is 0 bytes.

For the longest time my Organise Bookmarks > Library window was unpopulated. Now it seems to have data that mirrors my bookmarks. I do not know how it repopulated. I had 0 byte files with the unpopulated window also.

The places.sqlite file is around 350kb in size and does not seem to be effected by this problem.

Backup in HTML format produces a good backup copy.






Reproducible: Always

Steps to Reproduce:
1. Add bookmark - check newly created .json backup file - 0 bytes
2. Organise Bookmarks > Library > Backup creates a 0 byte file
3. Organise Bookmarks > Library > Export HTML creates a mirror image of my bookmarks
Actual Results:  
included in above

Expected Results:  
create a file greater than 0 bytes.

I downloaded the sqlite db manager to check the db integrity but I couldn't understand the table. One good point though, the db must be good, the manager did not report any errors. I removed the data manager.

Hope this helps.
Maybe in a way related to bug 402302.
Depends on: 402302
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → 3.0 Branch
(Reporter)

Comment 2

10 years ago
I debugged this in my limited way. The saved .json file sizes are no longer 0 bytes but in the 250kb area.

As reported, Export HTML produced a good file so I deleted (after saving) all 0 byte files in the bookmarksbackup folder and places.sqlite.

Firefox opened with a minimal bookmark toolbar. I imported the HTML file and the toolbar repopulated. I did a backup of the bookmarks to a .json file and all seems OK.

My places.sqlite file size is the same as before.

I suspect a corrupted database. The backup procedure crashed and produced a 0 byte file. It should have told me the problem (if possible) and rebuilt the database (if possible) in a perfect world.

The bottom line is the problem is fixed but the bug is NOT fixed.

Comment 3

10 years ago
most likely due to bogus tag children

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458683
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.