Weave shows many duplicates in log file

RESOLVED FIXED in 0.3

Status

P3
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: grenavitar, Unassigned)

Tracking

unspecified
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Weave 0.2.2

After trying many different actions in Weave, when I look at the log file I get meaningless duplicates (9 times for this bug, 15 times for another thing).  My most recent attempt was logging (I get a 503 error, but I think this is unrelated).  But it has happened when the login was successful by spamming "2008-07-07 08:41:09	Chrome.Window	INFO	Login successful" 15 times (version 0.2.0) as I reported: https://labs.mozilla.com/forum/index.php/topic,1152.msg4575.html

I don't know if these actions are actually being performed 15 times or just pasted to log each time.  I assumed this was happening to everyone but thunder asked me to post a bug so it might not be.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox
2. Log into Weave
3. Check log
Actual Results:  
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-09 22:41:57	Service.Main	INFO	Using server URL: https://services.mozilla.com/user/gren/
2008-07-09 22:42:27	Service.DAV	WARN	_makeRequest: got status 502
2008-07-09 22:42:27	Service.Util	ERROR	Login verification failed Error code: 502
2008-07-09 22:42:29	Async.Generator	ERROR	Exception: checkStatus failed


Expected Results:  
2008-07-09 22:41:57	Chrome.Window	INFO	Logging in...
2008-07-09 22:41:57	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-09 22:41:57	Chrome.Window	INFO	Weave version: 0.2.2


Windows XP default theme.  No crashing.  Does this both when Weave is functioning and when it's not functioning.  No idea if related to when Weave is slow.

Plugins: APNG Edit 1.4; BugMeNot 2.0; FireFTP 0.99.2; Google Gears 0.3.24.0; Pray Times! 1.1.3; Skype Extension 2.2.0.70 (disabled).

And build config (no idea if relevant)

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=25
(Reporter)

Comment 1

11 years ago
2008-07-09 23:08:36	Service.DAV	WARN	_makeRequest: got status 404
2008-07-09 23:08:37	Service.DAV	DEBUG	Creating path: meta
2008-07-09 23:08:37	Service.DAV	DEBUG	MKCOL request for meta
2008-07-09 23:08:40	Service.DAV	DEBUG	PUT request for meta/version
2008-07-09 23:08:43	Service.Main	TRACE	Retrieving keypair from server
2008-07-09 23:08:43	Service.Main	INFO	Fetching keypair from server.
2008-07-09 23:08:43	Service.DAV	DEBUG	GET request for private/privkey
2008-07-09 23:08:46	Service.DAV	WARN	_makeRequest: got status 404
2008-07-09 23:08:46	Service.DAV	DEBUG	GET request for public/pubkey
2008-07-09 23:08:48	Service.DAV	WARN	_makeRequest: got status 404
2008-07-09 23:08:49	Service.Main	DEBUG	Generating new RSA key
2008-07-09 23:08:50	Service.DAV	DEBUG	GET request for private/
2008-07-09 23:08:52	Service.DAV	WARN	_makeRequest: got status 404
2008-07-09 23:08:52	Service.DAV	DEBUG	Creating path: private
2008-07-09 23:08:52	Service.DAV	DEBUG	MKCOL request for private
2008-07-09 23:08:54	Service.DAV	DEBUG	GET request for public/
2008-07-09 23:08:57	Service.DAV	WARN	_makeRequest: got status 404
2008-07-09 23:08:57	Service.DAV	DEBUG	Creating path: public
2008-07-09 23:08:57	Service.DAV	DEBUG	MKCOL request for public
2008-07-09 23:09:04	Service.DAV	DEBUG	PUT request for private/privkey
2008-07-09 23:09:06	Service.DAV	DEBUG	PUT request for public/pubkey
2008-07-09 23:09:09	Service.Main	INFO	Weave scheduler enabled
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:09:09	Chrome.Window	INFO	Login successful
2008-07-09 23:14:09	Service.Main	INFO	Running scheduled sync
2008-07-09 23:14:09	Service.DAV	DEBUG	LOCK request for lock
2008-07-09 23:14:10	Service.DAV	WARN	_makeRequest: got status 405
2008-07-09 23:14:10	Async.Generator	ERROR	Exception: Could not acquire lock
2008-07-09 23:14:10	Async.Generator	DEBUG	Stack trace:
No traceback available.
This exception was raised by an asynchronous coroutine.
Initial async stack trace:
unknown (async) :: WeaveLockWrapper-63 (last self.cb generated at module:wrap.js:124 :: WeaveLockWrapper)
module:wrap.js:92 :: WeaveNotifyWrapper
module:async.js:232 :: AsyncGen_run
module:async.js:341 :: Async_run
module:async.js:361 :: Async_sugar
module:service.js:274 :: WeaveSvc__onSchedule
module:util.js:414 :: innerBind
module:util.js:454 :: EL_notify

I just got that when I logged in.  I had cleared my logs midway through the process after clicking login.  I post this because I think the 404 errors might show that it really is performing the actions multiple times rather than just pasting it to log since for the first few it's a 404 and then, apparently, the servers came up and it logged in (although I had been getting 503 errors, earlier).  Hopefully this helps.
(Reporter)

Comment 2

11 years ago
Also, an aspect I forgot to mention.  Upon the failed lock of my last comment, I got 9 error bubbles saying "Error While Syning" so they duplicating extends to error bubbles and not just the log file.

Comment 3

11 years ago
Very interesting.  One question... how many windows do you have open?
(Reporter)

Comment 4

11 years ago
I have 10 right now... it's quite possible I had 9 when I submitted this bug... and maybe even 15.

I just did a test and made sure I had 15 windows open--logged out, cleared logs, and logged back in.  I got 15 login confirmations.  This seems to be the same thing that happened with starting Weave Setup help on newer versions (and maybe why I've gotten some duplicates in the past? although, I've never gotten 9, luckily)

== my logs ==
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Chrome.Window	INFO	Logging in...
2008-07-10 05:05:04	Chrome.Window	INFO	User string: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
2008-07-10 05:05:04	Chrome.Window	INFO	Weave version: 0.2.2
2008-07-10 05:05:04	Service.Main	INFO	Using server URL: https://services.mozilla.com/user/gren/
2008-07-10 05:05:05	Service.Main	INFO	Fetching keypair from server.
2008-07-10 05:05:05	Service.Main	INFO	Weave scheduler enabled
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful
2008-07-10 05:05:05	Chrome.Window	INFO	Login successful

Comment 5

11 years ago
Aha, the problem is definitely connected to the number of windows you have open then.  We have code attached to the window that initiates a login/sync.  It's supposed to not do so multiple times, but I guess it's buggy.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Blocks: 468689
Priority: -- → P3
Target Milestone: -- → 0.3

Comment 6

10 years ago
This bug should be mostly fixed by:

http://hg.mozilla.org/labs/weave/rev/bb703579dd4c
http://hg.mozilla.org/labs/weave/rev/73c07629a2f0
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.