Closed Bug 444537 Opened 12 years ago Closed 10 years ago

Events disappear when I add an event to remote calendar

Categories

(Calendar :: Provider: ICS/WebDAV, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: s.s.harper, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Sunbird 0.8, 0.9

We have an .ics on a server with some calendar data within it.  When I enter in a new event and click on another day, the events in the remote calendar disappear.  I have to restart Sunbird by stopping it in the Task Manager.  When Sunbird is restarted, it returns to normal.  This only seems to happen when there is a lot of data in a calendar.

Reproducible: Always

Steps to Reproduce:
1. Add new calendar and choose on the network
2. Enter address of secure server and add username to identify the person 
3. Change colour of calendar.
4. Enter an event into the new calendar

Actual Results:  
You will need a calendar with plenty of entries for this to succeed.  Once you enter a new entry, all events will disappear.

Expected Results:  
The software should have kept the events on and this should have updated the server copy
If you have a calendar with many items, it could be that it just takes a while (admittedly a very long time) to write the items. If you kill the application in the meantime, then the partially written ICS file is probably corrupt. This could be bug 411799.
I understand what you are saying, but how come when I start Sunbird the events in the calendar appear instantly?  If too many events were the cause, maybe I would have encountered this problem just after the new calendar is installed?
Component: Sunbird Only → Provider: ICS/WebDAV
QA Contact: sunbird → ics-provider
Same behavior for Lightning on Thunderbird 2.x, Shredder 3.0b1pre.
In this case - closing mail client closes it's window, but process just stuck in some state (have no debug tools on my Windows, sorry). So, restarting mail agent _looks_like_ it was restarted, but actually, just brings the GUI for same (not killed yet) instance.
Events does not appear until thunderbird process killed and re-started explicitly.
2Steve: Could you close Sunbird and check if Sunbird process is still shown in process list? (Ctrl-Shift-ESC, then "Processes" tab).
My problem have the same root as yours.

Environment: 
Server: Apache + SVN/DAV (used to be WebDAV, same experience) + HTTPS + Basic Auth.
Client: Thunderbird 2.x+Lightning ?.? (latest), Shredder 3.0b1pre
Keywords: qawanted
No response for a while now, closing INCOMPLETE. Please reopen if you can reproduce or answer any unanswered questions.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.