If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Uploading XPI always fails with "Connection Interrupted"

VERIFIED DUPLICATE of bug 433958

Status

addons.mozilla.org Graveyard
Developer Pages
--
critical
VERIFIED DUPLICATE of bug 433958
9 years ago
2 years ago

People

(Reporter: mao, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
Since yesterday I'm trying to upload a new version of FlashGot, but every time I try, *after the browser is apparently done with the upload* (looking at the network traffic), the connection gets reset ("Connection Interrupted" on the XUL error page, NS_ERROR_NET_RESET from the channel).

I've done several attempts at different hours and from different networks, but this problem persists.

Not sure if related to bug 444381 (but there Alex talks about a "blank page").
(Reporter)

Comment 1

9 years ago
This morning I noticed that resolving addons.mozilla.org from an U.S. based host gives 63.245.209.31, while resolving from Europe gives 63.245.213.32.

So I tried to force resolution from by (Europe-based) box to 63.245.209.31, and the result changed slightly: now I get the blank page Alex talks about in bug 444381.

My guess is that we're reporting the same bug, and the "connection interrupted" message we get in Europe comes from a proxy.

Feel free to dupe this one if my guess is right, but could someone actually check?

It doesn't seem browser or configuration dependent either: I tried Safe Mode, Opera 9.51 and even Lynx...
Depends on: 444381
Justin, can someone take a look at this and see if it might be an IT issue? We've seen a ton of reports in the last couple weeks saying that when people try to upload an add-on it fails with a blank page. Giorgio did some debugging that might be useful above.

Comment 3

9 years ago
sure - think we'll need some help reproducing this from the amo team.  oremj can take a look on monday...has webdev looked at this as well?

Comment 4

9 years ago
connecting from India; amo resolves to 63.245.209.31 and leads to an empty page

Comment 5

9 years ago
(In reply to comment #4)
> connecting from India; amo resolves to 63.245.209.31 and leads to an empty page
> 

this is only when trying to upload an addon right?  Any more details like URL, actions, etc would be helpful.

Comment 6

9 years ago
> this is only when trying to upload an addon right?  Any more details like URL,
> actions, etc would be helpful.
> 
yes, only when uploading an addon (SQLite Manager; https://addons.mozilla.org/en-US/developers/add/5817)
Other observations:
1. time of the day did not matter; same error throuhout last 24 hrs.
2. Used Firefox, IE on Win XP/Vista. On firefox, different profiles too. Same error.
3. http headers show that the file is being sent to the server
4. uploaded a .csv file. Got an error that only .xpi is allowed
5. renamed the .csv file to .xpi. Got the error that no install.rdf present

That is, the server gets the xpi file, checks for an install.rdf and finds it too (perhaps does a lot of other things as well) but returns an empty page. the http response headers from the server contain 200 OK but no date, server, x-powered-by, etc.
(Reporter)

Comment 7

9 years ago
I managed to work-around by using the "Submit Add-on" button on the main developer page.
Uploading from there (https://addons.mozilla.org/en-US/developers/add) consistently works and apparently works like an update for existent extensions.

Again, trying the same from https://addons.mozilla.org/en-US/developers/add/220 (the proper "Upload New Version" link) is still broken.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433958
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.