Does not sign in on my own WebDAV server with error code 409

RESOLVED INVALID

Status

Cloud Services
General
--
major
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: Andreas Weller, Unassigned)

Tracking

({platform})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: https://services.mozilla.com/

I can't log into my WebDAV space provided by my ISP. I get an error 409

Reproducible: Always

Steps to Reproduce:
1. You have to use https://[username].mediencenter.t-online.de/dav/ as WebDAV space

Actual Results:  
2008-07-10 15:36:43	Service.DAV	WARN	_makeRequest: got status 409
2008-07-10 15:36:43	Service.Util	ERROR	Login verification failed Error code: 409
2008-07-10 15:36:44	Async.Generator	ERROR	Exception: Could not acquire lock
2008-07-10 15:36:44	Async.Generator	ERROR	Exception: checkStatus failed

Expected Results:  
Log in
(Reporter)

Comment 1

10 years ago
Created attachment 328870 [details]
Error.log (Brief an verbose)
(Reporter)

Comment 2

10 years ago
Created attachment 328871 [details]
Wireshark capture

May be the problem is on the provider's side. The tcp dump may help eliminating this option.
(Reporter)

Updated

10 years ago
Summary: Does not sign in with error code 409 → Does not sign in on my own WebDAV server with error code 409
(Reporter)

Comment 3

10 years ago
Hi.
I tried logging into my WebDAV with curl on the console. 

andreas@notebook:~$ curl -I -u USER:PASS --basic https://xxxxx.mediencenter.t-online.de/dav
HTTP/1.1 200 OK
Date: Fri, 11 Jul 2008 11:34:04 GMT
Server: Apache/2.0.55 (Debian) JETServ/2.2.18 CM4all-ModComa/0.4.6(libcoma/2.5.19.9) CM4all-Ticket/0.2.3 DAV/2 mod_apreq2-20051231/2.6.0
Set-Cookie: sid=[Nobody needs to know]; path=/
ETag: [USER]
Content-Type: httpd/unix-directory

But if I try to display the folder it's this:
andreas@notebook:~$ curl -u [USER]:[PASS] --basic https://xxxxx.mediencenter.t-online.de/dav
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>409 Conflict</title>
</head><body>
<h1>Conflict</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
 [no address given] and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
</body></html>

In the header you can see they are using cm4all - is there a known problem with some browsers?
Keywords: platform
OS: Windows XP → All

Comment 4

10 years ago
I'm no moz developer, but am interested in getting Weave to work with WebDAV.

The wireshark capture isn't very helpful because of SSL.

But your curl example is interesting, looks like Weave is expecting directory indexing to be available.
(Reporter)

Comment 5

10 years ago
I just installed the 0.2.3 version of Weave - the problem persists:
but now it displays "invalid username and/or password", which is 100% not true...

Regards,
  Andreas
(Reporter)

Comment 6

10 years ago
No fix in 0.2.4 

Comment 7

10 years ago
This does not appear to be a Weave bug.  HTTP error 409 means the server has some rule that prevents Weave's requests from being processed.

See here for more information:

http://www.checkupdown.com/status/E409.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

10 years ago
But with Linux I can mount it with davfs2 and on windows with Novell's NetDrive...

Regards,
  Andreas Weller

Comment 9

10 years ago
Weave uses a GET request with a directory for sign-on.  Most other WebDAV clients avoid using GET for directories (collections) and use PROPFIND instead.

This part of the WebDAV specification defines that GET *may* succeed but does not have any correlation to the collection:

  http://webdav.org/specs/rfc4918.html#rfc.section.9.4

Comment 10

10 years ago
Weave tries to stick to plain HTTP where possible, and only use additional WebDAV commands when necessary.

The WebDAV spec (linked to in comment #9) says it doesn't change the semantics of GET for collections, which means HTTP semantics apply.

Updated

9 years ago
Component: Weave → General
Product: Mozilla Labs → Weave
Target Milestone: -- → ---
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.