quotes a contact's name after inserting quote of a marked smiley

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: verve, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)
Build Identifier: 2.0.0.14

if i try to quote a smiley-image, it inserts a contact name.

Reproducible: Always

Steps to Reproduce:
1. Write a new E-Mail.
2. Insert a smiley via the toolbar.. like “:)”
3. Mark the smiley in your message and right-click on it.
4. Now choose “Insert quote”


Expected Results:  
The image just quoted.

Also disabled all addons.
Blogged on http://verve.scullar.de/?p=17
(Reporter)

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 1

11 years ago
What you observe is the intended behavior. If you highlight something in your composition window and then select "Paste", it will be replaced with whatever is on the clipboard (in your case, some contact name). The option "Paste as Quotation" behaves the same, just puts whatever you paste into a quote. 

To get the desired result, you have to highlight the smilie first, then select "Copy" to put it on the clipboard, the "Paste as Quotation" at the same spot.

-> INVALID (not a bug)
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.