If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Some GIFs are copied incorrectly

RESOLVED DUPLICATE of bug 249032

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 249032
9 years ago
9 years ago

People

(Reporter: Scott Johnson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

At least some GIFs copy from Firefox incorrectly, turning a white background black. The Yahoo! banner at http://l.yimg.com/a/i/ww/beta/y3.gif exhibits this behavior, while the Google banner at http://www.google.com/intl/en_ALL/images/logo.gif does not.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.yahoo.com
2. Copy and paste the "Yahoo!" banner from Firefox into either MS Word (I am using 2003) or MS Paint (Vista).
3. Do the same using Internet Explorer.
Actual Results:  
With Firefox, the background of the "Yahoo!" gif turns black. With IE, the background remains white. Also, 

Expected Results:  
Should maintain the same background (white) as seen on the web page and as captured by a copy-and-paste from IE.

If you copy-and-paste onto the desktop, then drag the same image into Word or Paint, the image looks fine.
(Reporter)

Comment 1

9 years ago
Same results with the images on this page: http://www.libsci.sc.edu/Chrisb/706/WebTransparentGif/TransGIF-Example.htm.

Therefore, this may be a problem with properly rendering transparent GIFs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 249032
You need to log in before you can comment on or make changes to this bug.