If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Why was this site blocked? button points to a unlocalized page

RESOLVED WORKSFORME

Status

www.mozilla.org
General
RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: Nukeador, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9) Gecko/2008061015 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9) Gecko/2008061015 Firefox/3.0

I've noticed that in Firefox 3 when you click on "Why was this site blocked?" in the anti-phishing UI you are pointed to a English-only version of this page: http://www.mozilla.com/en-US/firefox/phishing-protection/

Any idea why it does not point to the site with the explication like in beta?

Reproducible: Always

Steps to Reproduce:
1. Visit a phishing site (http://www.mozilla.com/firefox/its-a-trap.html)
2. Click on "Why was this site blocked?" button
Actual Results:  
You are redirected to http://www.mozilla.com/en-US/firefox/phishing-protection/

Expected Results:  
You should be redirected to the site with the reasons.
There is no page with detailed reasons why a specific phishing page was blocked, that page is only available for malware pages.  (A phishing page is always blocked for the same reason, that it pretends to be something it isn't...)

However, if you're saying that we aren't picking up the correct language for that page based on your browser locale, that is a bug, though we should change the bug summary, if so.
(Reporter)

Comment 2

9 years ago
Changing the summary and component.
Component: Phishing Protection → www.mozilla.org
Product: Firefox → mozilla.org
Summary: Why was this site blocked? button points to the wrong site → Why was this site blocked? button points to a unlocalized page
Version: unspecified → other
Component: www.mozilla.org → www.mozilla.com
Product: mozilla.org → Websites
QA Contact: phishing.protection → www-mozilla-com
Version: other → unspecified
http://mxr.mozilla.org/firefox/source/browser/app/profile/firefox.js#620

620 // FAQ URL
621 pref("browser.safebrowsing.warning.infoURL", "http://%LOCALE%.www.mozilla.com/%LOCALE%/firefox/phishing-protection/");

http://es-ES.www.mozilla.com/es-ES/firefox/phishing-protection/ doesn't exist (as in, not translated), so it redirects back to en-US.

--> WORKSFORME, as this is the correct path it's taking
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

9 years ago
So... why isn't this page ready for localization?
(Assignee)

Updated

6 years ago
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.