Closed Bug 444664 Opened 12 years ago Closed 12 years ago

Unable to install due to misreporting of OS version (requires Microsoft Windows 2000 or newer)

Categories

(Firefox :: Installer, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: lupatrian, Assigned: robert.strong.bugs)

References

Details

(Keywords: fixed1.9.0.2)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008071003 Minefield/3.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008071003 Minefield/3.1a1pre

Second occurrence in a week. I didn't report the first, which cleared up at the next build: DL Win32installer.exe; inst error - "Need Win NT/2000 or higher" (not exact wording). Today, I attempted to install a 2nd time - without re-downloading - and it installed without a problem. 

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Download nightly build win32installer.exe
2. Begin installation process
3.
Actual Results:  
"Error: Need Win NT/2000 or higher" (not exact wording). Installation does not proceed; clicking error's OK box closes FF install process.

Expected Results:  
As I have XP, which qual's as above NT/2000, it should have worked - and did upon retry. 

Not sure if FF or Win problem. 
FYI: I install over prev night's builds; don't uninstall first.
Version: unspecified → Trunk
Could you export the following registry key and attach it to this bug?
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags
and
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags

1. Open regedit.exe (you can do so by going to Start -> Run, typing
regedit.exe, and clicking OK.
2. Select in the tree view on the left under HKEY_CURRENT_USER
   Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags 
3. Export the values by selecting File -> Export, type hkcu-appcompat.reg, make a
note of where the file will be save to or save it to your desktop, and click
OK.
2. Select in the tree view on the left under HKEY_LOCAL_MACHINE
   Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags 
4. Export the values by selecting File -> Export, type hklm-appcompat.reg, make a
note of where the file will be save to or save it to your desktop, and click
OK.
4. Attach the exported files to this bug.

Thanks
Version: Trunk → unspecified
Version: unspecified → Trunk
No CURRENT_USER AppCompat folder listed.
Nothing in the file points to the problem.

(In reply to comment #0)
>...
> Second occurrence in a week. I didn't report the first, which cleared up at the
> next build: DL Win32installer.exe; inst error - "Need Win NT/2000 or higher"
> (not exact wording). Today, I attempted to install a 2nd time - without
> re-downloading - and it installed without a problem. 
Did you do anything differently the second time such as running as admin, changing the location on the filesystem of the installer before launching it, etc. ?
Nope - same.
Could this be related (an entry on Google about probs recognizing Win2K> made me think it might be): I have frequent system crashes; disk check always brings up same prob file - Firefox profile (c:\Documents and Settings\USER NAME\Application Data\Mozilla\Firefox\Profiles\ - and this time (I had never gotten the file name written down in time B4 today) it was the .default profile listed as the problem. (Folder also contains a .firefox profile, dated 1 day later than the default.) These crashes have been happening to me for quite awhile, but very frequent last 4 days. I've assumed it was ext overrides. I will back up prof's and delete/recreate, for now. 
The version is determined by calling GetVersion available from Windows so I doubt it... also, this has absolutely nothing to do with profiles.
Summary: Win32installer.exe/Nightly Build → Unable to install due to misreporting of OS version (requires Microsoft Windows 2000 or newer)
Hey Jim, I'd like to have you review installer patches if you are ok with it since we are a tad short handed on reviewers for the installer. I'm more than happy to walk you through these as well.
Assignee: nobody → robert.bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #329255 - Flags: review?(jmathies)
Does the installer have the ability to call win32 apis? If so, it seems a direct call to GetVersionEx might be a better solution.
AtLeastWin2000 is already using GetVersion though I am not able to reproduce so I'm unsure as to what exactly is failing here.
I can't find any reference to GetVersion returning invalid info. There's a lot out there about people mis-interpreting the results, but I'd assume the installer has it right. I'm not sure a one off fix for a single occurance is warnted, especially since we don't know what's causing the problem. The same problem may manifest itself with this fix. What do you think Robert?
I haven't found anything either about GetVersion returning invalid info though it will return the OS set via an exe's compatibility mode... this doesn't seem to be the problem here though. This specific part of the code is to prevent installing on systems prior to Win2K so I'm not terribly concerned about putting in a one off hack that will only be hit when a system fails the AtLeastWin2000 and will only allow the installer to continue.
Attachment #329255 - Flags: review?(jmathies) → review+
This sounds like a problem I submitted to the forums (asked on Sat 28 of Jun, 2008). I probably should have signed up and entered it here and I hope that reiterating it will help with finding a solution.  The url to the support forum entry is
 
http://support.mozilla.com/tiki-view_forum_thread.php?locale=en-US&forumId=1&comments_parentId=88420

the text of the forum entry is
----------------
FF3 incorrectly refuses to install on my system. (XP MCE 2002 SP2)
Firefox version: 3 Operating system: Microsoft Window XP, Media Center Edition, Version 2002, Service Pack 2

1. downloaded FF3
2. went to download folder
3. ran "Firefox Setup 3.0.exe"
4. go message: "Sorry, Firefox can't be installed. This version of Firefox requires Microsoft Windows 2000 or newer."

BUT: My system is "Microsoft Window XP, Media Center Edition, Version 2002, Service Pack 2" 
Checked in to mozilla-central

changeset:   16073:490aca1a9dd9
tag:         tip
user:        Robert Strong <robert.bugzilla@gmail.com>
date:        Sun Jul 20 13:20:34 2008 -0700
summary:     Bug 444664 - Unable to install due to misreporting of OS version (requires Microsoft Windows 2000 or newer). r=jmathies
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Comment on attachment 329255 [details] [diff] [review]
patch - safegaurd against AtLeastWin2000 not working properly

Drivers, this patch performs a second test that verifies the OS is not compatible with the application.
Attachment #329255 - Flags: approval1.9.0.2?
Component: OS Integration → Installer
QA Contact: os.integration → installer
Duplicate of this bug: 446211
Also, the reporter of Bug 446211 confirmed that this fixes the bug for them.
Whiteboard: [needs baking]
Some more info for Drivers...

This patch adds a test for OS version at the beginning of the installer and is extremely safe. The only time the code is used is after the test by GetVersion reports less than Win2K and then the registry keys are checked to make sure the OS is in fact less than Win2K.

You can verify this patch by setting the installer's file properties -> compatibility to run in compatibility mode for a version before Win2k.
Comment on attachment 329255 [details] [diff] [review]
patch - safegaurd against AtLeastWin2000 not working properly

Approved for 1.9.0.2. Please land in CVS. a=ss
Attachment #329255 - Flags: approval1.9.0.2? → approval1.9.0.2+
Whiteboard: [needs baking]
Checked in for 1.9.0.2 / Firefox 3.0.2

Checking in mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh;
/cvsroot/mozilla/toolkit/mozapps/installer/windows/nsis/common.nsh,v  <--  common.nsh
new revision: 1.42; previous revision: 1.41
done
Keywords: fixed1.9.0.2
You need to log in before you can comment on or make changes to this bug.