TM: Don't unbox & box values we never read or write in the trace.

RESOLVED DUPLICATE of bug 450234

Status

()

RESOLVED DUPLICATE of bug 450234
10 years ago
10 years ago

People

(Reporter: gal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Flag values as read as soon we actually use a context slot in the trace. Similarly, flag all slots we write. If we either read or write a slot, import it (it has to be a legal value even if we update it along one path of the tree only but then enter, take some other path, side exit and then try to write back). If we never touch the value, don't write it out.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450234
You need to log in before you can comment on or make changes to this bug.