If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Memory not being released when using Silverlight application

VERIFIED INCOMPLETE

Status

()

Firefox
General
VERIFIED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: bkejser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Hi

I wrote a Silverlight 2 Beta 2 application to handle massive file uploads. The program chunks files and make multiple http posts. For example, 250M file would consists of 100 2.5M http posts. The software works fine on IE6, IE7 and FF2. That is, the file uploads complete and memory usage is around 1-5M regardless of the file size. 

On Firefox 3, memory usage is a bit of a problem. For the first 5 - 15 seconds the amount of memory used is fairly stable. After which, memory usage increases at a linear rate. In my tests, uploading a 250M file will consume around 200M of memory. Furthermore, memory is not released until the tab running the Silverlight application is closed.

First of all, I'm not blaming FF3. In fact, the only reason I'm posting here is because the program works with FF2. I've also reported the problem to Microsoft in case this is purely a Silverlight problem.

Thaks

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I've heard Silverlight causes problems.  What did you find since comment 0?
Seems like there must be something documented by now.
What version of silverlight are you using? I see no big issues when using silverlight (not that it is used very much). So you have a reply from MS?
per http://www.wincert.net/news/1-latest-news/343-microsoft-silverlight-10-breaks-with-firefox-3.html the "conflict" should be gone
Also, silverlight 3 will be coming out in a month or so (July 10th is the last date I heard), so that will probably have a bunch of fixes in it too.
Does this happen with Firefox 3.5 or later and silerlight 3 or later?
Whiteboard: closeme 2009-09-10
please reopen if you can reproduce with newer verseions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2009-09-10

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.