Print preview window loads normal website if F5 is pressed after closing printing dialog

RESOLVED WORKSFORME

Status

()

defect
--
major
RESOLVED WORKSFORME
11 years ago
a year ago

People

(Reporter: mozbug, Unassigned)

Tracking

1.9.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

The "normal" website will load within the Print Preview Window if F5 is pressed after the printing dialog was closed. 

Furthermore the Preview Mode can not be closed using the Close-Button while the "normal" website is active. The X-Button (right top) does not end the Preview Mode but closes the firefox main window with all opened Tabs. (see bug# 386402)

Reproducible: Always

Steps to Reproduce:
1. Open any website, p.ex http://www.google.de/firefox
2. Go to Print Preview
3. Press F5 (nothing happens)
4. Click Print-Button and abort printing
5. Press F5 -> loading normal website into preview window
6. Click Close-Button does not end preview mode
7. Change some options (landscape etc.) -> window contains preview again
8. Close-Button ends preview mode


Expected Results:  
If F5 is pressed in preview mode, the website should be reloaded and the preview should be rerendered.

Updated

11 years ago
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → printing
Version: unspecified → 1.9.0 Branch

Comment 1

11 years ago
Confirmed here on same user agent, Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Possible solution:
Open Print Preview in a new window instead of the main browser window. That way in the event that it breaks, it could still be closed without disrupting anything else.

Note that this bug is <em>not</em> a duplicate of <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=126719">bug 126719</a>.
Depends on: 428013
WFM on Win10.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.