Unable to add Search Engine after deleting it

VERIFIED DUPLICATE of bug 353056

Status

()

Firefox
Search
VERIFIED DUPLICATE of bug 353056
10 years ago
10 years ago

People

(Reporter: George, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Normally when you go to a search site which you don't have a plugin for, you can add it by clicking the pull-down menu to the left of the search field and you'll see an option to add it (e.g. Add "Wikipedia (en)").

After deleting Wikipedia from the Manage Search Engine List, I was unable to re-add Wikipedia when I went to the Wikipedia site. Oddly, when I go to C:\Program Files\Mozilla Firefox\searchplugins and removed "wikipedia.xml", the option came back whenever I went to en.wikipedia.org.

The same is true of www.answers.com. For some reason, these 2 XML files are preventing the add option from appearing in the pull-down menu.

I figured these XML files are for the Restore Defaults option in Manage Search Engine List, since clicking it restored everything except Answers.com and Wikipedia (I removed "answers.xml" and "wikipedia.xml").

I tested this on several computers with Firefox 3. It is reproducible every time.  

Reproducible: Always

Steps to Reproduce:
1. Delete Wikipedia or Answers.com from Manage Search Engine List
2. Go to en.wikipedia.org or answers.com
3. Click search pull-down menu
Actual Results:  
Add "Wikipedia (en)" does not appear when visiting en.wikipedia.org

Expected Results:  
Add "so-and-so" should appear in the menu

Deleting or moving files "answers.xml" and "wikipedia.xml" from C:\Program Files\Mozilla Firefox\searchplugins will restore the Add option.

By doing this you will lose Answers.com and Wikipedia from the Restore Defaults function in Manage Search Engine List.
Yeah, you need to use "restore default set" to restore default shipped engines, you can't re-add them from the web. We never actually remove defaults, we just hide them.

This is a duplicate of bug 353056.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353056
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.