If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

top crash [@ nsIFrame::GetAncestorWithView()] when trying to open a PDF file via Google search [caused by Acrobat Reader and others]

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P1
critical
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: Suseelan B Sarin, Unassigned)

Tracking

(4 keywords)

1.9.0 Branch
x86
Windows XP
crash, testcase, topcrash, user-doc-complete
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(4 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Searched for 'remote management ppt' in google. Clicked on the first result which was a pdf. First firefox just got killed. Started it again and selected restore session. It did not restore the last tab properly. A part of my search string was present in the text box (remote managem) and it was showing the previous page. I searched again and got the old result again. Clicking on it caused an error message to be displayed and it crashed again. 

Reproducible: Always

Steps to Reproduce:
1.Search for 'remote management ppt' in google
2. Click on the first result
Actual Results:  
Firefox crashed.

Expected Results:  
Should have displayed the pdf file.

I have adobe reader 8.0 installed on my system. I also have acrobat 6.0 professional and distiller installed. 

I have taken a screen shot when it failed second time. I have put it at 
http://suseelan.googlepages.com/FF3crash.jpg
http://www.mversen.de/crash/
(Reporter)

Comment 2

9 years ago
I tried doing it in the safe mode and there was no crash at this time. The file opened in adobe reader 8 inside the firefox tab.
If it works in the safemode then it's casued by an addon.
Can you reproduce this hang always in the normal mode and it works in the safemode ?
Then go to tools/addons and dsiable the addons one-by one to find the addon that is causing this problem.
(Reporter)

Comment 4

9 years ago
I could reproduce it always in normal mode. Then I started disabling addons. First disabled AVG safe search. But it was still happening. Then disabled *download embedded* (Version 0.5). It started working fine after that.  

Btw, the link that I am trying to open is: http://www.pmimontgomery.org/pdf/Presentations/Challenges%20of%20Remote%20Management.pdf
(Reporter)

Comment 5

9 years ago
Just uploaded the screenshot where it is working fine after disabling the "Download Embedded" addon

http://suseelan.googlepages.com/FF3crash-NoDE.jpg
I will CC the developer of that addon aeruder@ksu.edu.
This addon doesn't seem to come with a binary component and Firefox should not crash if the addon is only with JS/XUL, such addons can only hang/freeze Firefox.
(AFAIK).

You are seeing a crash and no hang/freeze, right ?
Then please follow the instructions in the URL from comment #1 and post a crash ID of your crash, thanks.


(Reporter)

Comment 7

9 years ago
Reported crash:
068c1d07-52aa-11dd-8747-001cc45a2ce4	7/16/2008	1:40 AM
0  	xul.dll  	nsIFrame::GetAncestorWithView  	 mozilla/layout/generic/nsFrame.cpp:3435
1 	xul.dll 	nsPluginInstanceOwner::Init 	mozilla/layout/generic/nsObjectFrame.cpp:4288
2 	xul.dll 	nsObjectFrame::PrepareInstanceOwner 	mozilla/layout/generic/nsObjectFrame.cpp:1635
3 	xul.dll 	nsObjectFrame::Instantiate 	mozilla/layout/generic/nsObjectFrame.cpp:1683
4 	xul.dll 	nsPluginStreamListener::OnStartRequest 	mozilla/content/html/document/src/nsPluginDocument.cpp:127
5 	xul.dll 	nsDocumentOpenInfo::OnStartRequest 	mozilla/uriloader/base/nsURILoader.cpp:290
6 	xul.dll 	nsHttpChannel::CallOnStartRequest 	mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp:756
7 	xul.dll 	xul.dll@0x2e5fe7 	
Summary: Crash when trying to open a pdf file via google search → Crash when trying to open a pdf file via google search [@ nsIFrame::GetAncestorWithView]
Severity: normal → critical
Component: General → Layout
Keywords: crash
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → 1.9.0 Branch
Duplicate of this bug: 448621
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Summary: Crash when trying to open a pdf file via google search [@ nsIFrame::GetAncestorWithView] → [download embedded] Crash when trying to open a pdf file via google search [@ nsIFrame::GetAncestorWithView]

Updated

9 years ago
Duplicate of this bug: 452766
Duplicate of this bug: 454839
Keywords: topcrash
This is showing up as the #14 topcrash for Firefox 3.0.3 (and comments mention opening PDFs).

Comment 13

9 years ago
Greetings.
Have same problem where firefox crashes when loading pdf page.
Had disabled ALL add-ons/plugins. same problem.
Here is a sample web page
  http://www.belk.com/AST/Featured/Promo_Details/BelkDaysE/belk_days_pdf_email.jsp

I use Kaspersky 2009. Have same problem while disabled.
Have reinstalled Kaspersky, Mozilla and acrobat version 9

Thanks in advance
Jay: You must restart Firefox if you disabled the addons to be sure that the addons are disabled. That you crash opening PDFs doesn't mean that you are seeing this bug unless you use the addon "download embed". You have to follow comment#1 and post a crash ID and we can look at the reason but don't morph bugs like this one if you have a different issue.

Comment 15

9 years ago
Thank you for response!
I did restart firefox without any add-ons - same crash..
But..
I may have different problem.. I had installed acrobat 9 onto PC - not as an embedded add-on within firefox.

On Nov. 7th, I wiped my disk and re-installed Mozilla, Acrobat, 
ant-virus, and other files...
That resolved the problem.
I will pay attention to changes and re-test often to see if problem occurs.

Sorry to be a bother, 
Jay E.
For the extension, it is enough to have this in order to crash:
window.addEventListener("focus", function(evt) {
	var this_embeds = window.content.document.getElementsByTagName("embed")[0];
	return true;
}, true);
Flags: blocking1.9.1?
Perhaps this is also related to and Adobe pdf problem (although one of the duped bug was also occurring with flash, it seems).
Component: Layout → Plug-ins
QA Contact: layout → plugins
Created attachment 349002 [details]
zipped testcase, uses enhanced privileges

I tried to come up with a standalone testcase, using enhanced privileges, that crashes with the relevant stacktrace, but I get this stacktrace:
http://crash-stats.mozilla.com/report/index/0012b945-67ec-4dd7-afe4-ec9420081119?p=1
0  	nppdf32.dll  	nppdf32.dll@0x639d  	
1 	user32.dll 	InternalCallWinProc 	
2 	user32.dll 	UserCallWinProcCheckWow 	
3 	user32.dll 	CallWindowProcAorW 	
4 	user32.dll 	CallWindowProcA 	
5 	xul.dll 	PluginWndProc 	modules/plugin/base/src/nsPluginNativeWindowWin.cpp:360
6 	user32.dll 	InternalCallWinProc 	
etc...

But that stack looks more like that one from bug 434593.

Comment 19

9 years ago
I can't say with 100% certainty, but I believe all crashes that have nppdf32.dll called from CallWinProc somewhere on the stack are the same problem
Given that this is a topcrash we should attempt to figure this one out.
Assignee: nobody → jst
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
Target Milestone: --- → mozilla1.9.1b3
Are people still seeing this? I've so far been unable to reproduce this. I fairly sure the crash with the stack mentioned in comment #8 has already been fixed, but I'm not sure about the one in comment #18, but that one looks like a plugin bug, not a Firefox bug. I'll investigate more, but if others can test if this is still reproducable I'd appreciate it.

Comment 22

9 years ago
The crash with the stack in comment #18 is a plug-in bug and will be fixed in an upcoming release of Acrobat/Reader.  It is *not* a Firefox bug.
This probably shouldn't be a blocker then. Renominating to put it back in the consideration queue...
Flags: blocking1.9.1+ → blocking1.9.1?
Yup, not a blocker, give the above comments.
Flags: blocking1.9.1? → blocking1.9.1-

Comment 25

9 years ago
Crash in Comment 18 fixed with 9.1 release of Acrobat/Reader.  When you install or patch, please verify that the new nppdf32.dll is indeed put into Firefox's plug-ins folder (it should be, we've had occasional reports that it was not). You can find it in the Reader installation "Browser" folder.
Keywords: testcase
Created attachment 380743 [details]
zipped testcase2

This crashes fairly quickly when opening the file named 'crash1.htm' and then switching the rendering engine to IE, using the IETab extension:
https://addons.mozilla.org/en-US/firefox/addon/1419
This is with Firefox trunk, it doesn't seem to crash with Firefox3.0.x.

http://crash-stats.mozilla.com/report/index/051d6da2-4716-476f-a65c-ab7942090531?p=1
0  	 	@0x16  	
1 	user32.dll 	user32.dll@0x8815 	
2 	user32.dll 	user32.dll@0x1a012 	
3 	user32.dll 	user32.dll@0x1a997 	
4 	npietab.dll 	npietab.dll@0x209a 	
5 	npietab.dll 	npietab.dll@0x22bc 	
6 	user32.dll 	user32.dll@0x8815 	
7 	user32.dll 	user32.dll@0x1a012 	
8 	user32.dll 	user32.dll@0x1a997 	
9 	xul.dll 	PluginWndProc 	modules/plugin/base/src/nsPluginNativeWindowWin.cpp:360
10 	user32.dll 	user32.dll@0x8733 	
11 	user32.dll 	user32.dll@0x8815 	
12 	user32.dll 	user32.dll@0x18e9f 	
13 	user32.dll 	user32.dll@0x18eeb 	
14 	ntdll.dll 	ntdll.dll@0xe472 	
15 	user32.dll 	user32.dll@0x16422 	
16 	user32.dll 	user32.dll@0x1683d 	
17 	user32.dll 	user32.dll@0x29b42 	
18 	npietab.dll 	npietab.dll@0x12419 	
19 	npietab.dll 	npietab.dll@0x126af 	
20 	npietab.dll 	npietab.dll@0x126d5 	
21 	npietab.dll 	npietab.dll@0x1273f 	
22 	npietab.dll 	npietab.dll@0x252a 	
23 	npietab.dll 	npietab.dll@0x3841 	
24 	npietab.dll 	npietab.dll@0x3470 	
25 	xul.dll 	nsPluginNativeWindow::CallSetWindow 	obj-firefox/dist/include/nsPluginNativeWindow.h:101
26 	xul.dll 	nsPluginNativeWindowWin::CallSetWindow 	modules/plugin/base/src/nsPluginNativeWindowWin.cpp:499
27 	xul.dll 	nsPluginHostImpl::InstantiateEmbeddedPlugin 	modules/plugin/base/src/nsPluginHostImpl.cpp:3379
28 	xul.dll 	nsObjectFrame::InstantiatePlugin 	layout/generic/nsObjectFrame.cpp:880
29 	xul.dll 	nsObjectFrame::Instantiate 	layout/generic/nsObjectFrame.cpp:1787
30 	xul.dll 	nsObjectLoadingContent::Instantiate 	content/base/src/nsObjectLoadingContent.cpp:1763
31 	xul.dll 	nsObjectLoadingContent::EnsureInstantiation 	content/base/src/nsObjectLoadingContent.cpp:781
32 	xul.dll 	nsHTMLPluginObjElementSH::GetPluginInstanceIfSafe 	dom/base/nsDOMClassInfo.cpp:9263
33 	xul.dll 	nsHTMLPluginObjElementSH::SetupProtoChain 	dom/base/nsDOMClassInfo.cpp:9343
34 	xul.dll 	nsHTMLPluginObjElementSH::PostCreate 	dom/base/nsDOMClassInfo.cpp:9465
35 	xul.dll 	XPCWrappedNative::GetNewOrUsed 	js/src/xpconnect/src/xpcwrappednative.cpp:595
36 	xul.dll 	XPCConvert::NativeInterface2JSObject 	js/src/xpconnect/src/xpcconvert.cpp:1146
37 	xul.dll 	XPCConvert::NativeData2JS 	js/src/xpconnect/src/xpcconvert.cpp:472
38 	xul.dll 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2561
39 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1590
40 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1386
41 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1447
42 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5197
43 	xul.dll 	XPC_NW_FunctionWrapper 	js/src/xpconnect/src/XPCNativeWrapper.cpp:531
44 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1386
45 	js3250.dll 	js_Interpret 	js/src/jsinterp.cpp:5171
46 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1394
47 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1447
48 	js3250.dll 	js_GetPropertyHelper 	js/src/jsobj.cpp:4332
49 	js3250.dll 	js_Interpret 	js/src/jsinterp.cpp:4443
50 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1394
51 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1652
52 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:561
53 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
54 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
55 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1087

I guess this is an IETab issue?
I also crashed with Firefox trunk with the [@ nsIFrame::GetAncestorWithView] stack:
http://crash-stats.mozilla.com/report/index/07c1fbc2-aaea-4f58-862b-58d592090531?p=1
0  	xul.dll  	nsIFrame::GetAncestorWithView  	 layout/generic/nsFrame.cpp:3548
1 	xul.dll 	nsPluginInstanceOwner::Init 	layout/generic/nsObjectFrame.cpp:4772
2 	xul.dll 	nsObjectFrame::PrepareInstanceOwner 	layout/generic/nsObjectFrame.cpp:1715
3 	xul.dll 	nsObjectFrame::Instantiate 	layout/generic/nsObjectFrame.cpp:1770
4 	xul.dll 	nsObjectLoadingContent::Instantiate 	content/base/src/nsObjectLoadingContent.cpp:1763
5 	xul.dll 	nsObjectLoadingContent::EnsureInstantiation 	content/base/src/nsObjectLoadingContent.cpp:781
6 	xul.dll 	nsHTMLPluginObjElementSH::GetPluginInstanceIfSafe 	dom/base/nsDOMClassInfo.cpp:9263
7 	xul.dll 	nsHTMLPluginObjElementSH::SetupProtoChain 	dom/base/nsDOMClassInfo.cpp:9343
8 	xul.dll 	nsHTMLPluginObjElementSH::PostCreate 	dom/base/nsDOMClassInfo.cpp:9465
9 	xul.dll 	XPCWrappedNative::GetNewOrUsed 	js/src/xpconnect/src/xpcwrappednative.cpp:595
10 	xul.dll 	XPCConvert::NativeInterface2JSObject 	js/src/xpconnect/src/xpcconvert.cpp:1146
etc...


I also am able to crash with the IETab extension with this stack:
http://crash-stats.mozilla.com/report/index/33704bcb-76c9-4e12-99bb-2b26f2090531?p=1
0  	mozcrt19.dll  	free  	 obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:6387
1 	xul.dll 	nsHTMLPluginObjElementSH::GetPluginJSObject 	dom/base/nsDOMClassInfo.cpp:9676
2 	xul.dll 	nsHTMLPluginObjElementSH::SetupProtoChain 	dom/base/nsDOMClassInfo.cpp:9355
3 	xul.dll 	nsObjectFrame::NotifyContentObjectWrapper 	layout/generic/nsObjectFrame.cpp:2103
4 	xul.dll 	nsObjectFrame::TryNotifyContentObjectWrapper 	layout/generic/nsObjectFrame.cpp:1822
5 	xul.dll 	nsObjectFrame::Instantiate 	layout/generic/nsObjectFrame.cpp:1795
6 	xul.dll 	nsObjectLoadingContent::Instantiate 	content/base/src/nsObjectLoadingContent.cpp:1763
7 	xul.dll 	nsObjectLoadingContent::TryInstantiate 	content/base/src/nsObjectLoadingContent.cpp:1723
8 	xul.dll 	nsObjectLoadingContent::LoadObject 	content/base/src/nsObjectLoadingContent.cpp:1177
9 	xul.dll 	nsObjectLoadingContent::LoadObject 	content/base/src/nsObjectLoadingContent.cpp:977
10 	xul.dll 	nsHTMLSharedObjectElement::StartObjectLoad 	content/html/content/src/nsHTMLSharedObjectElement.cpp:432
11 	xul.dll 	nsHTMLSharedObjectElement::StartObjectLoad 	content/html/content/src/nsHTMLSharedObjectElement.cpp:133
12 	xul.dll 	nsRunnableMethod<nsHTMLObjectElement,void>::Run 	obj-firefox/dist/include/nsThreadUtils.h:264
13 	xul.dll 	nsContentUtils::RemoveScriptBlocker 	content/base/src/nsContentUtils.cpp:4395
14 	xul.dll 	xul.dll@0x3bff6f
Resolving as INVALID since this is fixed in the, now released, Adobe Acrobat Reader 9.1. Sad that it's still a top crash though... I wonder how fast Acrobat users upgrade? (Currently #6 for Firefox 3.0.11.)
Assignee: jst → rsherry
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Summary: [download embedded] Crash when trying to open a pdf file via google search [@ nsIFrame::GetAncestorWithView] → top crash [@ nsIFrame::GetAncestorWithView()] when trying to open a PDF file via Google search
Blocks: 500578
Ok, the latest development version of IETab doesn't seem to have this issue.
chofmann: If/When we get a plugin-update page, we should be sure to add Adobe Acrobat Reader to it. This crash is currently #1 for Firefox 3.0.12.
Summary: top crash [@ nsIFrame::GetAncestorWithView()] when trying to open a PDF file via Google search → top crash [@ nsIFrame::GetAncestorWithView()] when trying to open a PDF file via Google search [caused by Acrobat Reader]
Whiteboard: [Fixed by Acrobat Reader 9.1]

Comment 31

8 years ago
cww, this is a good candidate for a support article...  e.g.  "if you have hit this crash you need to update to latest versions of flash..."

Updated

8 years ago
Keywords: common-issue?

Comment 32

8 years ago
Update reader, I assume you mean...
Keywords: user-doc-needed

Comment 33

8 years ago
We see PDF crashes somewhat commonly.
Keywords: common-issue? → common-issue+
Actually, I'm reopening this bug. It's not fixed by Adobe's update after all and it's not actually clear to me that only the Adobe plug-in (and Download Embedded) are causing this.

In comment 27, Martijn shows that the crash happens with the Adobe plug-in (nppdf32.dll), version 9.1.0.163 (that's bp-07c1fbc2-aaea-4f58-862b-58d592090531 for those keeping track). However, in comment 25, Rudi says this is fixed in version 9.1 of Acrobat Reader. It's clear that's not the case.

Similarly, this crash is still the #1 topcrash on 3.0.x and, in some reports, no Acrobat is present at all (like bp-0316686a-2ae5-4f6e-a361-d47952090907). In those cases, other third party DLLs *are* present, but it's not clear which ones may be causing this issue.

At the very least, we need to investigate what other add-ons or plug-ins are causing this issue so we can tell users to upgrade or remove them.

Reopening and changing the summary a bit.
Assignee: rsherry → nobody
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: top crash [@ nsIFrame::GetAncestorWithView()] when trying to open a PDF file via Google search [caused by Acrobat Reader] → top crash [@ nsIFrame::GetAncestorWithView()] when trying to open a PDF file via Google search [caused by Acrobat Reader and others]
Whiteboard: [Fixed by Acrobat Reader 9.1]
Target Milestone: mozilla1.9.1b3 → ---
I meant to add, this does *not* appear in the topcrash list for 1.9.1, but *does* happen there.

http://crash-stats.mozilla.com/query/query?product=Firefox&version=Firefox%3A3.5.2&branch=1.9.1&date=&range_value=1&range_unit=weeks&query_search=signature&query_type=exact&query=nsIFrame%3A%3AGetAncestorWithView%28%29&do_query=1

It happened 486 times in the last week, with varying modules, including one I found with nppdf32.dll (bp-993d7dc4-f62a-4cc9-971d-e72cd2090906). It's not clear to me that Acrobat is the *cause* of that particular crash, but it's not clear that it's not either.

I should also add that Rudi said the crash that was fixed was that of comment 18, a completely different stack than the one this bug is about (but with similar conditions).

Comment 36

8 years ago
I looked at various crashes in the crashes page and I don't see anything that indicates it's the bug that was fixed in 9.1; I also believe this is a separate bug.

In Reader's 9.1 bug the stack would show a Windows SendMessage or PostMessage causing a WndProc call to unloaded code, and this is not the case with the stack top being GetAncestorWithView.

Comment 37

8 years ago
Created attachment 399253 [details]
crash analysis for 3.5.2

analysis for 483 crashes shown here: http://crash-stats.mozilla.com/report/list?product=Firefox&branch=1.9.1&version=Firefox%3A3.5.2&query_search=signature&query_type=exact&query=nsIFrame%3A%3AGetAncestorWithView()&date=&range_value=1&range_unit=weeks&do_query=1&signature=nsIFrame%3A%3AGetAncestorWithView()

Comment 38

8 years ago
Created attachment 399256 [details]
crash analysis for 3.0.13

As above but for the 500 crashes here:

http://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A3.0.13&query_search=signature&query_type=exact&query=&date=&range_value=1&range_unit=weeks&do_query=1&signature=nsIFrame%3A%3AGetAncestorWithView()
user-doc-complete
<https://support.mozilla.com/en-US/kb/Firefox+crashes+when+working+with+PDF+files?bl=n>
Keywords: user-doc-needed → user-doc-complete

Comment 40

8 years ago
Doesn't look like that many people have this specific crash at least on SUMO.  Will re-flag if we find out otherwise.
Keywords: common-issue+

Updated

8 years ago
Component: Plug-ins → PDF (Adobe)
Flags: blocking1.9.1-
Product: Core → Plugins
QA Contact: plugins → adobe-reader
Version: 1.9.0 Branch → unspecified

Updated

8 years ago
Component: PDF (Adobe) → Plug-ins
Product: Plugins → Core
QA Contact: adobe-reader → plugins
Version: unspecified → 1.9.0 Branch
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsIFrame::GetAncestorWithView()]

Comment 41

6 years ago
Only appearing on 3.0, 3.5 and 3.6 in the past 4 weeks. Resolving as works for me.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.