Open Bug 444983 Opened 14 years ago Updated 9 years ago

Enlarging Default Font size for *Display* should not enlarge printed font size {Options | Display | Formatting | Fonts & Colors | Default Font | Size}

Categories

(MailNews Core :: Printing, defect)

defect
Not set
minor

Tracking

(Not tracked)

People

(Reporter: mkassler, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: 2.0.0.14 (20080421)

For use on wide screens it would be desirable to be able to increase the font size displayed in the compose window WITHOUT changing the font size used to send or to print the message. This request has been posted in the Forum but no one replied with a way to do this. The proposed enhancement would be particularly useful for those who find it hard to see small letters on a wide screen.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
The solution is to use plain text composition. See bug 406643.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406643
Duplicate of this bug: 444981
Duplicate of this bug: 444982
Duplicate of this bug: 444985
Duplicate of this bug: 445119
Please REOPEN this bug. It is not a duplicate of bug 406643. The solution to bug 406643 indicates how text size can be increased in the Compose window. However, that solution simultaneously increases text size when transmitted and printed out. I am seeking a solution that 'de-links' the text size displayed in the Compose window (so that this can be made as large or small as one likes) from the text size used to transmit a message or to print it out.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Quoting bug 406643 comment #1)
> Sounds like you have set the font size to something large (in Options |
> Composition | General). You should probably let that be the normal size. If you
> want larger fonts for your "own" view you should be able to change that in
> Options | Display | Formatting | Fonts...

This works for both plain-text and HTML composition, the text in the compose window is increased in size whereas no change of size is given in the sent message. It depends whether you change the sizes in the Composition or the Display preferences. To this extent, bug 406643 and this one are identical.

http://kb.mozillazine.org/Font_settings_in_Thunderbird

The part different from bug 406643 is the printing size. With increasing the display size, the printed characters are increased proportionally, including headers. The factor here are the dpi settings provided from the OS or the layout.css.dpi pref. Thus, to compensate for the increased size when printed, the dpi setting would need to be increased by the same ratio, which would also affect any other object (including menu and pane elements) measured in points.

http://kb.mozillazine.org/Layout.css.dpi

So, the underlying request here may be to uncouple printed from displayed sizes
without the need of adjusting the dpi setting, sounds valid to me.
I have verified the bug 406643 Display workaround on both Thunderbird 2.0.0.14 (Windows/20080421) and 3.0a2pre (2008071703), so this definitely works. For printing, I found bug 120800 addressing a similar issue for browser. This was resolved WFM, so whatever fixed it doesn't seem to apply in the same way for Mail/News printing as the display size of a message has a direct influence on its printed size.

A potential workaround is to reduce scaling in the Page Setup dialog. Thus,
with a 32px variable- and 26px fixed-width size specification at 50% scaling, I'm getting a close equivalent of 16px and 13px at 100%. While display size affects unformatted text and can be reduced to its intended size in this way, HTML text with a specified size or images are however not affected by the display-setting size, thus they would be unintendedly reduced as well. This makes the workaround of limited value.

I'm confirming this enhancement request therefore for the printing part. Even though it is similar to bug 120800, the display/scale-compensation workaround
is rather unsatisfactory and involves somewhat complicated mathematics to get
to a desired point size, even if just printing plain-text messages. It would
be beneficial to have a dedicated "Base print size" preference (preferably in points rather than pixels), which could then be used as a factor in the print point-size calculation from the displayed pixel sizes and dpi values.
Status: UNCONFIRMED → NEW
Component: Message Compose Window → MailNews: Printing
Ever confirmed: true
OS: Windows Vista → All
Product: Thunderbird → Core
QA Contact: message-compose → printing
Hardware: PC → All
Version: unspecified → Trunk
Summary: Enlarge font in compose window without enlarging printed font or font used to send messages → Enlarge font in compose window without enlarging printed font
I agree with the suggestion that it would be desirable for a user to specify a default print size preference in points. I look forward to this feature being implemented.
Product: Core → MailNews Core
Michael, good news: after landing of bug 738194 (reported by me), expected with release of TB24, it will be much easier to just increase the displayed font size in composition window by *zooming*, i.e. without affecting sent or printed font size in any way:

- Ctrl++ to zoom in; Ctrl+- to zoom out; Ctrl+0 to reset zoom to 100%
- or Ctrl+mousewheel to zoom in/out
- or View > Zoom menu

However, this bug still stands: Changing default size of displayed font in options should not affect printing (sent msg no longer affected afaics).
Severity: enhancement → minor
Summary: Enlarge font in compose window without enlarging printed font → Enlarging Default Font size for *Display* should not enlarge printed font size {Options | Display | Formatting | Fonts & Colors | Default Font | Size}
(In reply to Thomas D. from comment #10)
I want to support the idea with zooming, because the display resolution is the real problem.
Having a small font size in the composition window makes the text unreadable when typing,
otherwise receivers get big letters in their message.
Is it possible to add a default zoom in the options?
This bug report seems to be related to bug 204632.
You need to log in before you can comment on or make changes to this bug.