In <folderWidgets.xml>, "Error: aFolder is null", loading "Junk Settings" panel

VERIFIED FIXED in Thunderbird 3

Status

Thunderbird
Account Manager
VERIFIED FIXED
10 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: rkent)

Tracking

({regression})

Trunk
Thunderbird 3
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

1.18 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071303 Thunderbird/3.0a2pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008071301 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

After checking bug 438647 comment 24, I noticed another error:

1. Start SM or TB.
2. Create a dumb profile and (POP3) account.
3. Open Account Settings.
4. Select "Junk Settings", on the (POP3) account or/then the "Local Folders".
   [Try this again, if the error doesn't show up "immediately"...]
4r.
{{
Error: aFolder is null
Source File: chrome://messenger/content/folderWidgets.xml
Line: 616
}}

A (SM) Venkman stack can look like:
{{
#0: function selectFolder(aFolder=null:null) in <chrome://messenger/content/folderWidgets.xml> line 616
#1: function onInit(aServerId=string:"mailbox://nobody@Local%20Folders", aPageId=string:"am-junk.xul") in <chrome://messenger/content/am-junk.js> line 60
#2: function restorePage(serverId=string:"mailbox://nobody@Local%20Folders", pageId=string:"am-junk.xul") in <chrome://messenger/content/AccountManager.js> line 968
#3: function showPage(pageId=string:"am-junk.xul", serverId=string:"mailbox://nobody@Local%20Folders") in <chrome://messenger/content/AccountManager.js> line 766
#4: function onAccountClick(tree=XULElement:{7}) in <chrome://messenger/content/AccountManager.js> line 727
#5: function onselect(event=Event:{0}) in <chrome://messenger/content/AccountManager.xul> line 1
 6: select / x-jsd:native-code
#7: function onxblmousedown(event=MouseEvent:{0}) in <chrome://global/content/bindings/tree.xml> line 951
}}

|selectFolder()| doesn't like |aFolder=null:null|;
I don't know if we should blame the caller or the callee...
Flags: blocking-thunderbird3?

Comment 1

10 years ago
WFM over here on version 3.0a2pre (2008071303) /linux - not using global inbox

Comment 2

10 years ago
Thunderbird, that is.
(Assignee)

Comment 3

10 years ago
Serge, in your preferences file, what entries do you have that contain "spamActionTargetAccount"? I suspect that your preference is not set for one of your server accounts.
Serge, please can you answer comment 3. Thanks.
(Reporter)

Comment 5

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/20080813031200 Shredder/3.0b1pre] (nightly) (W2Ksp4)

Still there, per comment 0 steps (no global, no download).

(In reply to comment #3)
> Serge, in your preferences file, what entries do you have that contain "spamActionTargetAccount"?

None on the disk.

In <about:config>,
{{
mail.server.default.spamActionTargetAccount / default / string / (empty)
}}
(Assignee)

Comment 6

10 years ago
I can reproduce this on SM and TB by setting up POP3 to not use the Global Inbox. The error occurs when I select junk settings on Local Folders, then again on the POP3 account (or vice versa). Since I've looked at this code as part of bug 444220, I'll take this as well.
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Assignee: nobody → kent
Status: ASSIGNED → NEW
(Assignee)

Comment 7

10 years ago
Created attachment 333790 [details] [diff] [review]
Stop nulling variables
Attachment #333790 - Flags: superreview?(neil)
Attachment #333790 - Flags: review?(neil)

Comment 8

10 years ago
Comment on attachment 333790 [details] [diff] [review]
Stop nulling variables

No, I don't think this is right.
Attachment #333790 - Flags: superreview?(neil)
Attachment #333790 - Flags: superreview-
Attachment #333790 - Flags: review?(neil)
Attachment #333790 - Flags: review-

Comment 9

10 years ago
This is actually a regression from bug 368303 - if you look carefully at the linked section of the patch you'll notice that only one of the references to pendingServerId was replaced :-(
(Reporter)

Updated

10 years ago
Keywords: regression
(Assignee)

Comment 10

10 years ago
Created attachment 333894 [details] [diff] [review]
Fix regression per Neil's suggestion

So this is what you had in mind, right?
Attachment #333790 - Attachment is obsolete: true
Attachment #333894 - Flags: superreview?(neil)
Attachment #333894 - Flags: review?(neil)

Updated

10 years ago
Attachment #333894 - Flags: superreview?(neil)
Attachment #333894 - Flags: superreview+
Attachment #333894 - Flags: review?(neil)
Attachment #333894 - Flags: review+

Comment 11

10 years ago
Comment on attachment 333894 [details] [diff] [review]
Fix regression per Neil's suggestion

I think we might want to fix this on branch too for both Thunderbird and SeaMonkey.
Attachment #333894 - Flags: approval1.8.1.17?
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
Keywords: checkin-needed
Checked in (to trunk), changeset id 103:adbc45171106
Keywords: checkin-needed
(Reporter)

Updated

10 years ago
No longer blocks: 413781, 438647
(Assignee)

Comment 13

10 years ago
(In reply to comment #11)
> (From update of attachment 333894 [details] [diff] [review])
> I think we might want to fix this on branch too for both Thunderbird and
> SeaMonkey.
> 
I cannot see any effects of this on branch. Can you produce an STR that shows an issue worth fixing? 
(Reporter)

Comment 14

10 years ago
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1a2pre) Gecko/20080816031236 Shredder/3.0b1pre] (nightly) (W2Ksp4)

V.Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-thunderbird3?
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 15

10 years ago
(In reply to comment #13)
> I cannot see any effects of this on branch. Can you produce an STR that shows
> an issue worth fixing? 

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17pre) Gecko/2008081603 Thunderbird/2.0.0.17pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.17pre) Gecko/20080816 SeaMonkey/1.1.12pre] (nightly) (W2Ksp4)

I can't reproduce this bug (with same steps) on 1.8(.1) branch either.
Yet, as bug 368303 was "fixed1.8.1.2", it shouldn't hurt to port this fix there.
(Assignee)

Comment 16

10 years ago
(In reply to comment #15)
> 
> I can't reproduce this bug (with same steps) on 1.8(.1) branch either.
> ... it shouldn't hurt to port this fix
> there.
> 
I thought the standard was much higher than "it shouldn't hurt" before we ported fixes to branch.
(Reporter)

Comment 17

10 years ago
(In reply to comment #16)
> I thought the standard was much higher than "it shouldn't hurt" before we
> ported fixes to branch.

It is ... That was just my 2 cts...
Comment on attachment 333894 [details] [diff] [review]
Fix regression per Neil's suggestion

If we can't reproduce on branch, then we shouldn't accept the risk of taking the fix.  That said, the risk does look awfully small.
Attachment #333894 - Flags: approval1.8.1.17? → approval1.8.1.17-

Updated

6 years ago
No longer blocks: 368303
(Reporter)

Updated

6 years ago
Blocks: 368303
You need to log in before you can comment on or make changes to this bug.