<hr> size and placement computed against the wrong area

VERIFIED DUPLICATE of bug 22563

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 22563
18 years ago
16 years ago

People

(Reporter: Devoti Paolo, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000613
BuildID:    2000061311

While the text is correctly placed in the expected screen area the line is
misplaced and larger. It seems computed against the full window instead of the
currently available area

Reproducible: Always
Steps to Reproduce:
1.open the url or the provided html


Actual Results:  the small line is properly placed in the table area (black text)
the long line is misplaced

Expected Results:  the long line should be just on top of the green text	

<html>
<BODY BGCOLOR="White">
<TABLE ALIGN="Left" WIDTH="20%"><TR>
<TD VALIGN="Top">
text text text text text text text text text text text text text
text text text text text text text text text text text text text
text text text text text text text text text text text text text
<hr width=75%>
text text text text text text text text text text text text text

</TD>
</TR></TABLE>


<font color="005000" size="-1" face="Arial">

<br><br><hr width=75%> text text text text text text text text text text text
text text
text text text text text text text text text text text text text
text text text text text text text text text text text text text

Comment 1

18 years ago
This bug does exist, however I'm not 100% certain that it's not an error related
to the somewhat relaxed html support in other browsers (I tested it also in
4.7).  Leaving unconfirmed for this reason.  This was tested with nightly build
2000070408.
(Reporter)

Comment 2

18 years ago
IMHO the correct behaviour should be 
"draw the line within the current text margins "
Netscape 4.7, IE5 and Opera 4 are following this criterion
It is deferrable but it should not be left unconfirmed

Comment 3

18 years ago
over to HTML Element
Assignee: asa → clayton
Status: UNCONFIRMED → NEW
Component: Browser-General → HTML Element
Ever confirmed: true
QA Contact: doronr → petersen

Comment 4

18 years ago
Pierre, can you please triage.
Assignee: clayton → pierre

Comment 5

18 years ago
The problem is that the ALIGN=LEFT on the table is making it float, so the area 
that the width is computed against is the entire width of the screen.

This is a dup of bug 22563.

*** This bug has been marked as a duplicate of 22563 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
verifying
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.