History Sidebar and 'Show All History' blank. Auto-complete still working.

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: scientus, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

History sidebar and Organize history are blank except for that windows history after history pane has been opened.

Auto-complete still works (did not check if it is updating for new entries)

90 day history setting--however I visit a lot of web pages. DB is large.


Problem has been present for probably a month, is starting to really annoy me.

Reproducible: Always

Steps to Reproduce:
1.Ctrl-H or Ctrl-Shift-B




Greasemonkey, Noscript, Adblock Plus, Menu-manipulator, ChatZilla, Firebug, Web Developer, Download StatusBar, more minor ad-ons.
(Reporter)

Comment 1

10 years ago
correction Show All History ie Ctrl-****-H blank, not Organize Bookmarks
Summary: History sidebar and Organize history are blank. Auto-complete still working. → History Sidebar and 'Show All History' blank. Auto-complete still working.
Try creating a new profile and copy the file places.sqlite from your old to your new profile and see if it works.
http://kb.mozillazine.org/Profile_Folder
Component: History → Places
QA Contact: history → places
Version: unspecified → 3.0 Branch
(Reporter)

Comment 3

10 years ago
did not wo(In reply to comment #2)
> Try creating a new profile and copy the file places.sqlite from your old to
> your new profile and see if it works.
> http://kb.mozillazine.org/Profile_Folder
> 

did not work, was blank in other profile(with imported places.sqlite). Auto complete continues to function.
Then it is likely that the problem is in your places.sqlite. Backup your bookmarks and import them again in a new profile.
(Reporter)

Comment 5

10 years ago
instead i just moved my places.sqlite folder out of my profile and let firefox make a new one. If there is no way to recover it i will probably just deleate then
Since the cause of the corruption is unclear and there is no testcase attached, resolving WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.