Weave Sign-In Dialog "Cancel" button doesn't actually cancel anything, while I'm signing in

RESOLVED FIXED in 0.4

Status

P3
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: dholbert, Assigned: Mardak)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Steps to reproduce:
 1. Open up Weave Sign In Dialog (Click Weave icon, choose "Sign In").
 2. Click "Sign In" on dialog.
 3. Press "Cancel" at any time while Weave is signing in.

ACTUAL RESULTS:
  Dialog disappears, which seems to indicate that Weave has accepted your command, but **Weave still signs in**.

EXPECTED RESULTS:
  *Option A) Weave cancels your sign-in. (Weave status bar should go back to "Offline"/"Sign In".)
  *Option B) "Cancel" button is disabled during the sign-in process (since it doesn't seem to have any useful purpose at that time).

Option B seems simpler to me.
(Though if Labs actually wants in-progress Weave Sign-Ins to be cancellable, then "Cancel" should be available actually work, per Option A)

VERSION INFO:
Ubuntu Linux 8.04
Firefox 3.0.0
Weave 0.2.4
(Reporter)

Comment 1

11 years ago
(In reply to comment #0)
> (Though if Labs actually wants in-progress Weave Sign-Ins to be cancellable,
> then "Cancel" should be available actually work, per Option A)

oops - I meant "should be available _and_ actually work"
(Reporter)

Comment 2

11 years ago
(In reply to comment #0)
> EXPECTED RESULTS:
> [...]

  *Option C) Perhaps the "Cancel" button could change a "Hide" button while Weave is undergoing its sign-in process, and it's function would remain the same -- make the dialog go away, but continue logging in.

This seems like a reasonable option, because it more accurately describes what the button does (at least currently).
Were you listening in to our meeting today?  This is exactly what Chris suggested ;-)  Though he was talking about the modal sync dialog, not the sign in dialog.
(Reporter)

Comment 4

11 years ago
Nope, I wasn't. :)  A "Hide" button sounds like a great idea for both sign in and sync dialogs.

My point with this bug, though, is that Weave already has a "Hide" button for the sign-in dialog -- it's just labeled "Cancel" instead of "Hide". :)

Updated

10 years ago
Blocks: 468689
Priority: -- → P3
Target Milestone: -- → 0.3

Updated

10 years ago
Target Milestone: 0.3 → 0.4

Updated

10 years ago
No longer blocks: 468689
(Assignee)

Comment 5

10 years ago
http://hg.mozilla.org/labs/weave/rev/681fbeb9b875

Just relabel Cancel to Hide (but keep around the original (localized) label in case we fail)
Assignee: nobody → edilee
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → FIXED
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Blocks: 486434
(Assignee)

Updated

10 years ago
Blocks: 486331
Component: Weave → General
Product: Mozilla Labs → Weave
Version: Trunk → unspecified
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.