build js shell on mozilla-central/tracemonkey MSVC called with wrong arguments on jsinterp.cpp

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: bc, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
with the patch in bug 436872 the following warnings is issued during make -f Makefile.ref for opt or debug.

cl -FoWINNT5.1_OPT.OBJ/ -c -O3 -fstrict-aliasing -fno-exceptions -fno-rtti -D_X86_=1 -DXP_WIN -DXP_WIN32 -DWIN32 -D_WINDOWS -D_WIN32 -DWINVER=0x500 -D_WIN32_WINNT=0x500 -nologo -W3   -UDEBUG -DNDEBUG -UDEBUG_bclary -IWINNT5.1_OPT.OBJ   -DEXPORT_JS_API jsinterp.cpp

cl : Command line warning D9002 : ignoring unknown option '-O3'

cl : Command line warning D9002 : ignoring unknown option '-fstrict-aliasing'

cl : Command line warning D9002 : ignoring unknown option '-fno-exceptions'

cl : Command line warning D9002 : ignoring unknown option '-fno-rtti'


the build still fails with the same error mentioned in bug 436872

js.cpp(2032) : error C2664: 'JS_ValueToInt32' : cannot convert parameter 3 from
'intN *' to 'int32 *'
        Types pointed to are unrelated; conversion requires reinterpret_cast,
C-style cast or function-style cast
Flags: in-testsuite-
Flags: in-litmus-

Comment 1

10 years ago
The warnings are caused by the problem described in bug 401048, USE_MSVC is checked before it is set in config/WINNTx.y.mk. This bug also means the JS shell is build without PGO.
Depends on: 401048
(Reporter)

Comment 2

10 years ago
Makefile.ref is doa.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.