Textbox auto-complete dropdown should hide when insert char from front, but not

RESOLVED DUPLICATE of bug 497541

Status

()

RESOLVED DUPLICATE of bug 497541
11 years ago
9 years ago

People

(Reporter: bayin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

When I type in a textbox, if the phrase matches any previous input from the beginning, the auto-complete drop down shows.

If the phrase does not match, auto-complete drop down should hide.

But it is not always working, for example, when I change a few words from the beginning but keep the latter part, the auto-complete drop down still shows.

Reproducible: Always

Steps to Reproduce:
1. Open a page that has editable textbox, for example google
2. type two words: "foo bar" and type Enter key, see the result page, 
3. go back to google page, type foo bar, now auto-complete prompted.

// everything works as expected so far

4. double click on "foo", type something different, for example, "koo", the auto-complete prompt should hide now, because I am searching for "koo bar", but it did not. Also, if enter any arrow key or enter key, the old "foo bar" will replace the content I just typed.

Comment 1

11 years ago
I'm surprised this is the only report on this bug.  I don't believe it showed up until version 2.0.  

The auto-complete appears to only be called if the cursor is at the end of a one-line text field.  I would think the function is being called, but is returning if the cursor isn't at the end of the field.

I would imagine this to be a simple bug to fix.  I might even see if I can read the code well enough to help.
This should be resolved by bug 497541 in Firefox 3.6.  If not, please reopen.

Thanks for the report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497541
You need to log in before you can comment on or make changes to this bug.