Scrolling keeps going on when mousedown on the scrollbarbutton and mouseup somewhere in scrollbar

RESOLVED FIXED

Status

()

Core
Event Handling
RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: smaug)

Tracking

({fixed1.9.1, regression})

Trunk
x86
Windows XP
fixed1.9.1, regression
Points:
---
Bug Flags:
blocking1.9.1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
To reproduce:
- Mousedown on the scrollbar buttton, keep the mouse button pressed
- Then move the mouse somewhere else in the scrollbar

Actual result:
Notice that the scrollbar keeps moving, it doesn't even matter that you release the mouse button.

Actual result:
The scrollbar should stop scrolling.

This regressed between 2008-06-22 and 2008-06-23.
I have no idea how to get a bonsai link, lately, maybe a fixed bugs list between those dates is useful?
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&product=Core&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&resolution=FIXED&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=2008-06-21&chfieldto=2008-06-23&chfield=resolution&chfieldvalue=FIXED&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
I have some more builds and I see a regression between 2008-06-22 22 and 2008-06-23 04: http://hg.mozilla.org/index.cgi/mozilla-central/shortlog/a78c4eeaf51c Olli Pettay - Bug 438241, and also Michael Ventnor with 3 checkins all around the same time within this range. 
Especially the different local times are making it difficult and possibly not error-free.. 
(Assignee)

Comment 2

10 years ago
ah, probably me :(

Comment 3

10 years ago
Regression from bug 438241 confirmed by local backout.
Blocks: 438241
(Assignee)

Comment 4

10 years ago
And this is so for me. If I finally could get event propagation work
properly when event is dispatched to native anonymous content...
Assignee: nobody → Olli.Pettay
(Assignee)

Comment 5

10 years ago
Created attachment 329821 [details] [diff] [review]
possible patch

I'll think this still some more, but this should do it. The event propagation
was stopped too early inside native anonymous subtree. So either
stop propagation when event is being handled in a native anon content (root
for the native anon subtree) or if event is dispatched to non-native anon content
but its related target is somewhere in its native anonymous subtree.
Cases when both target and related target are in native anon subtree (but not
necessarily in the same one) make this even more complicated :(
(Assignee)

Comment 6

10 years ago
Created attachment 329846 [details] [diff] [review]
simpler

relatedTarget->FindFirstNonNativeAnonymous() ==
target->FindFirstNonNativeAnonymous()
isn't needed anymore, but I want to add some DEBUG_smaug code.

I need to find some reasonable way to test this all automatically...
I tested this bug and other relevant bugs, no regressions.
The printf doesn't show anything bad.
Attachment #329846 - Flags: review?(jst)
(Reporter)

Updated

10 years ago
Flags: blocking1.9.1?
(Assignee)

Updated

10 years ago
Attachment #329846 - Flags: superreview?(jst)

Updated

10 years ago
Attachment #329846 - Flags: superreview?(jst)
Attachment #329846 - Flags: superreview+
Attachment #329846 - Flags: review?(jst)
Attachment #329846 - Flags: review+
(Assignee)

Comment 7

10 years ago
Wed Aug 27 14:11:12 2008 +0300 (at Wed Aug 27 14:11:12 2008 +0300)
changeset 18444	c9bc394e507a
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 452668

Updated

10 years ago
Duplicate of this bug: 420944
(Assignee)

Updated

10 years ago
Attachment #329846 - Flags: approval1.9.0.4?
Attachment #329846 - Flags: approval1.9.0.4? → approval1.9.0.4-
Comment on attachment 329846 [details] [diff] [review]
simpler

not approved for 1.9.0.4, doesn't meet the new stricter criteria. Users will get this in 3.1

Updated

10 years ago
Flags: blocking1.9.1? → blocking1.9.1-
Keywords: fixed1.9.1

Updated

8 years ago
No longer depends on: 627158
You need to log in before you can comment on or make changes to this bug.