Import of .ics breaks with missing DTEND (Cause: WebCalendar PHP application creates invalid ics files)

RESOLVED INVALID

Status

Calendar
Import and Export
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: mail6000, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.51 (Windows NT 5.1; U; en)
Build Identifier: Lightning 0.8, build 2008033120

When I sync Lightning 0.8 with WebCalendar v1.2.b1 the (re-import) to Lightning fails sometimes with the following error message:

[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [calIIcalComponent.startTime]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/uwe.R-E-H/Application%20Data/Thunderbird/Profiles/default.n97/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItemBase.js :: anonymous :: line 548"  data: no]


I narrowed the source of this problem down to the all-day events, which are handled differently in the ics-files of Lightning and WebCalendar. While Lightning includes a DTEND, WebCalendar doesn't.

From Lightning:

BEGIN:VEVENT
CREATED:20080716T104734Z
LAST-MODIFIED:20080716T104743Z
DTSTAMP:20080716T104734Z
UID:e2938896-e5d1-4fc2-ad43-50010b0052dd
SUMMARY:test
DTSTART;VALUE=DATE:20081202
DTEND;VALUE=DATE:20081203
TRANSP:TRANSPARENT
END:VEVENT


From WebCalendar:

BEGIN:VEVENT
UID:e2938896-e5d1-4fc2-ad43-50010b0052dd
LAST-MODIFIED:20080716T104956Z
SUMMARY:test
DESCRIPTION:test
CLASS:PUBLIC
STATUS:CONFIRMED
ATTENDEE;ROLE=OWNER;PARTSTAT=ACCEPTED;CN="test-user":MAILTO:mail@domain.test
DTSTART;VALUE=DATE:20081202
DTSTAMP:20080716T105028Z
END:VEVENT

My interpretation of rfc2445 is that both would be valid (which is confirmed also by http://severinghaus.org/projects/icv/). But Lightning breaks with the above given error message.

For the moment I just avoice all-day events and just make them 24h long. But it would be nice if this could be supported in the future. Thanks!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Reporter, could you please attach a sample ics file and some steps for reproduction for investigation? thanks!
(Reporter)

Comment 2

10 years ago
Created attachment 329841 [details]
3 events exported from Lightning, two of which all-day

I entered three test events in Lightning and exported them locally. This file can also be re-imported without any problems.
(Reporter)

Comment 3

10 years ago
Created attachment 329842 [details]
The same events exported to WebCalendar and then re-downloaded

This file contains the same three events, which were exported (published) from Lightning, to WebCalendar and then downloaded again. The file should be valid code, but breaks Lightning's import.
(Reporter)

Comment 4

10 years ago
The problem seems to be somewhat more complex than I thought before. I tried to narrow the problem down to one "offending" event, but then this did not break the import to Lightning... It seems like the problem is caused only by a combination or sequence of events...

Sorry for not providing the attachments earlier. And many thanks in advance for looking into this.
Attachment #329842 - Attachment mime type: application/octet-stream → text/plain
Attachment #329841 - Attachment mime type: application/octet-stream → text/plain

Comment 5

10 years ago
BEGIN:VEVENT
UID:cbbe7ade-28ce-43b4-82af-52ecf14bb714
LAST-MODIFIED:20080716T151756Z
SUMMARY:test 2
DESCRIPTION:test 2
CLASS:PUBLIC
STATUS:CONFIRMED
ATTENDEE;ROLE=OWNER;PARTSTAT=ACCEPTED;CN="test user";MAILTO:=test@domain.test
DTSTART;VALUE=DATETIME:20080724T000000
DTEND;VALUE=DATETIME:20080726T000000
DTSTAMP:20080716T151825Z
END:VEVENT

datetime is not an allowed parameter, it should be date-time with a dash
http://tools.ietf.org/html/draft-ietf-calsify-rfc2445bis-07#section-3.3.5

invalid, also see bug 419262
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Summary: Import of .ics breaks with missing DTEND → Import of .ics breaks with missing DTEND (Cause: WebCalendar PHP application creates invalid ics files)
You need to log in before you can comment on or make changes to this bug.