Update from hourly to a current nightly fails when Avast Pro 4.8 is installed

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: jmjeffery, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

When running an hourly build and trying to 'Update' to the current nightly build the 'Updater' is getting stuck in a loop. 

1. Help->Check for Updates 
2. Update is found and downloads OK
3. Restart Now 
4. Minefield will close and appears to be starting the shutdown/update process
5. Minefield will then restart and present the 'Update' dialog box saying to 'Update now' Clicking the 'Restart' then again closes Minefield, and restarts the application without applying the update.
6. Help->Check for Updates does not show any pending updates, clicking 'Check for..' presents the Update dialog box, but its not able to find the update and is now stuck in a loop.  

Not sure what I clicked when, but there was one dialog box shown that the download was 'paused' and the 'resume' button was grayed out.  It was paused at 9.1 meg out of 9.1 meg.

I have disabled Windows Defender, and my AV software and after clearing out the updater files and retrying, the update still fails into an endless loop of restarts...
Can you provide a regression range?
Regression testing has become difficult under the new moz-cen stuff and I don't know if there is an hourly archive anymore.  

The process for tracking down the range should be the same and the builds at
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/
would be a good place to start if you are able to
I have a few builds and the 06/18/1900hrs (approx) build works.
The 07/05/1838 (appros) build does NOT work. 

While I have had some problems going from nightly-to-nightly others have reported no issues with nightly->nightly.  That's why I'm testing from an 'hourly' build updating to a current nightly. 

I guess what I have is a start anyway.  I didn't download a lot of hourly's because for awhile while things were pretty much dead on moz-cen there was no point.  

OK I failed again this morning going from nightly->nightly
Testing the regress range I find:
0705 Nightly is OK - update works
0705 1838hrs build noted in comment #4 does not work - 

Hope this helps 
Tried updating this morning with a new Profile, same result - trying to apply the partial update, got a warning that could not install due to already running.  Repeated attempts to 'apply update' that is showing under Help results in same.  Perhaps a Vista only issue - as it never gets to the UAC prompt it appears.

I believe the mystery is solved, but don't like the findings.
I had recently downloaded and installed Avast Pro (as a replacement for Nortons) and all seemed 'ok' 
I just removed the AV this evening and have now done 3 updates from various build dates to the current nightly without any problems.  

I will close this tomorrow providing the update works tomorrow as expected.  
Sorry for the trouble. 

Avast Pro 4.8 was the version I was using - all set to factory defaults

(Reporter)

Updated

10 years ago
Summary: Update from hourly to a current nightly fails → Update from hourly to a current nightly fails when Avast Pro 4.8 is installed
Partial update went smoothly again today without any AV on the system at the moment. 

Robert, any ideas ?  Is it our issue or something with Avast ?  Strange the updates work with the nightly of 7/5 and fail with a later hourly.  Did we or they, or both change something that would affect this ?  

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1a1pre) Gecko/2008072003 Minefield/3.1a1pre Firefox/3.0 ID:2008072003
No idea why avast would be keeping the file in use. Could you try again with avast and attach the update log files from the failed update?
This is like taking a kid to the doctor.  I just re-installed Avast Pro 4.8.1201 and updated the def's, removed/installed 3.1a1pre from yesterday, 7/18, and ran the updater - all went smoothly..

I will watch it over the next few days and see what happens.  There is also an update to Avast just released today... will grab that update later tonight and see how it goes. 

I'm going to close this, partials, and full-pushes are working after a re-install of Avast.  So no idea why it worked up to a certain build and stopped. 

Thanks for everyone's time.

Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.