If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multipart JPEG (MJPEG) stream/session remains open until Firefox is closed.

RESOLVED DUPLICATE of bug 373701

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 373701
9 years ago
9 years ago

People

(Reporter: TJ Haeser, Unassigned)

Tracking

3.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; MEGAUPLOAD 2.0)
Build Identifier: 3.1a1pre

Firefox is one of the few browser which supports viewing of multipart, sequential JPEG (also sometimes called MJPEG) streams from the server and this is a neat feature. But this seems to have been broken during the transition from Firefox 2 to 3. When viewing such a stream, Firefox continues transfering the JPEG data from the server even if I close the site's tab or go to another site using the original site's tab. The transfer (as shown by traffic logging) is only stopped when the browser is closed. This is in contrast with version 2.x, where even going to a different page than the JPEG stream would close the connection (which is the expected behavior).

Reproducible: Always

Steps to Reproduce:
1. Visit a site which serves multipart JPEGs, such as an installation of the open source Zoneminder video recording software (www.zoneminder.com)
2. Close the tab, or go to a completely, unrelated site using the same tab
3. Observe the traffic exchange between the server and your machine.
Actual Results:  
You'll see Firefox is still transfering the JPEGs, causing an unnecessary additional load on the server.
Close Firefox and watch how finally the traffic stops.

Expected Results:  
As soon as I opened a different page or closed the tab, the JPEG transfer should have stopped.

Tested on Firefox 3.0 and the latest Minefield (3.1a1pre). On version 2.x, everything happens as expected.

I'm filing this as Major, because it's a real problem if you depend on it.
(Reporter)

Comment 1

9 years ago
Confirmed this on other operating systems. Changed Version to 3.0 branch.
OS: Windows XP → All
Version: unspecified → 3.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373701
You need to log in before you can comment on or make changes to this bug.