Norwegian Nynorsk and Bokmål not listed in 'Preferences | Languages | Add...'

VERIFIED FIXED

Status

()

Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Karl Ove Hufthammer, Assigned: Frank Tang)

Tracking

({polish})

Trunk
x86
All
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+]patch in hand, need review. ETA:8/4)

(Reporter)

Description

18 years ago
In 'Preferences | Languages | Add...', there is a list of languages. In this
list 'Norwegian (Nynorsk)' (language code: 'nn') and 'Norwegian (Bokmål)' (lc:
'nb') is missing.

(Norwegian has two official written forms, Nynorsk and Bokmål. Both have an
official (i.e. ISO) two-letter language code.)

Some people prefer Nynorsk and some people prefer Bokmål. Therefore, there
should be three choices: Norwegian (lc: 'no'), Norwegian (Nynorsk) (lc: 'nn')
and Norwegian (Bokmål) (lc: 'nb').

BTW, I know of at least two large sites that will use content negotiation to
choose between Nynorsk and Bokmål.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

18 years ago
Tao, could you look at this?
Assignee: nhotta → tao

Comment 2

18 years ago
I've actually promised Juraj that I would update this list.
Currently nb and nn are available on the master list but not
enabled. It is a simple matter of turning on these
items for the list but what we need to do is review the whole
list and settle on the final list for Beta 2.

I would like to do this as part of overall updating of 
language.properties file.

Note that there is no L10n implication for this since
language and regions names have been extracted out into
other files. 
(Reporter)

Comment 3

18 years ago
> I've actually promised Juraj that I would update this list.
> Currently nb and nn are available on the master list but not
> enabled. It is a simple matter of turning on these
> items for the list but what we need to do is review the whole
> list and settle on the final list for Beta 2.

What's the review for? Shouldn't *all* languages listed at <URL: http://lcweb.loc.gov/standards/iso639-2/englangn.html > and the updates at <URL: http://lcweb.loc.gov/standards/iso639-2/codechanges.html > be listed?

Comment 4

18 years ago
The list itself should contain all the possible lang-region
pairs, but it is not a good idea to "turn on/display in the list" 
the languages for which we have no charset support currently. 
Because the accept-language list is sent to servers telling
them that the client can accept that language, we should not
send a LANG code which we don't support/display in the product.
(Reporter)

Comment 5

18 years ago
> The list itself should contain all the possible lang-region
> pairs, but it is not a good idea to "turn on/display in the list"
> the languages for which we have no charset support currently.
> Because the accept-language list is sent to servers telling
> them that the client can accept that language, we should not
> send a LANG code which we don't support/display in the product.

But language and charset is completely independent. I can write an English page in pure ASCII, in UTF-8, UTF-16 or even EUC-JP (by using entity references).

Of course some languages are commonly used together with a specific charsets (e.g. EUC-JP and Japanese or iso-8859-1 and English), but they *don't have too* (and I guess more and more pages will start using UTF-8). Removing languages from the Accept-Language list serve little purpose.

Also, there *is* an Accept-Charset header <URL: http://www.freesoft.org/CIE/RFC/1945/93.htm > (though I don't know if it's deprecated).

Comment 6

18 years ago
I am sorry about the misuse of the term "charset" in my comment
above. The "support" I am talking about is a lot more than
just "charset" support. We need to be able to have proper 
rendering support, font handling, etc. to claim full
support. The fact that Unicode covers many language
in terms of encoding does not make it possible for us to say 
that we support language "X". 
As to the Accept charset support, we will not be implementing
that -- I asked publicly if anyone cared about not doing
Accept-charset in the mozilla-i18n list and noone cared enough to
answer.
(Reporter)

Comment 7

18 years ago
OK, I understand now.

Comment 8

18 years ago
Hi, Frank:


I won't have cyclce to handle this in PR2. Please reassign to whoever owns 
Juraj's bugs.

Thanks
Assignee: tao → ftang
(Assignee)

Comment 9

18 years ago
momoi- nb and nn is *NEW* language code added in additional to no. nb and nn is 
NOT region code here. We have not add nb and nn to the language list. Turn it as 
true won't make it work.

See http://lcweb.loc.gov/standards/iso639-2/codechanges.html for details.
(Assignee)

Comment 10

18 years ago
To fix this bug, it mean we need to 
1. add entries to xpfe/global/resources/locale/en-US/languageNames.properties
according to http://lcweb.loc.gov/standards/iso639-2/codechanges.html 
+nb = Norwegian Bokm&#229;l
+nn = Norwegian Nynorsk

2. add entries to intl/locale/src/language.properties
+ nn.accept=true
+ nb.accept=true
(Assignee)

Comment 11

18 years ago
forget about my comment. I am wrong. The nb and nn have already been added. We 
just need to change the nb=false and nn=false to true
Status: NEW → ASSIGNED

Comment 12

18 years ago
Frank, I'll get the review done by Thu morning, if you're willing
to check this in. (If necessary, I can get the review done by 
Wed., too).
(Assignee)

Comment 13

18 years ago
patch in hand. need review
Keywords: nsbeta3, patch, polish
Whiteboard: patch in hand, need review.
(Assignee)

Comment 14

18 years ago
nsbeta3 + per i18n bug meeting
Whiteboard: patch in hand, need review. → [nsbeta3+]patch in hand, need review.
(Assignee)

Updated

18 years ago
Whiteboard: [nsbeta3+]patch in hand, need review. → [nsbeta3+]patch in hand, need review. ETA:8/4
(Assignee)

Comment 15

18 years ago
Fix the spelling and turn them into true.
tao- please correct the spelling in the localized build. Thanks
(Assignee)

Comment 16

18 years ago
mark it fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 17

17 years ago
Verified as fixed in 2000-09-06-08 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.