Advanced Search for "Only bugs changed between" works differently depending on whether an item in the list is selected

RESOLVED DUPLICATE of bug 294937

Status

()

Bugzilla
Query/Bug List
RESOLVED DUPLICATE of bug 294937
10 years ago
4 years ago

People

(Reporter: Lucas Malor (mail: c6kfnkn2uc AT snkmail DOT c0m), Unassigned)

Tracking

({uiwanted})

Details

(URL)

In Advanced Search, if you select a date range in "Only bugs changed between:" option, Bugzilla returns bugs that their _last_ change is between the date range. Example: http://preview.tinyurl.com/wrongbugzquery/

But, if you select something in "where one or more of the following changed:", date range is valid even if the change done to the bug is not the last one. Example: http://preview.tinyurl.com/5jjtaw/

I think a good solution is to add another element to "where one or more of the following changed:" list, named "[Last Change]" and selected by default.

Updated

10 years ago
Summary: Different behaviours with "Only bugs changed between" option in Advanced Search → Advanced Search for "Only bugs changed between" works differently depending on whether an item in the list is selected

Comment 1

10 years ago
Hmm, or just have it behave as expected.

Comment 2

10 years ago
Yes, if the user fills in both dates they probably mean to search for any change, not just the most recent one. Although if they only fill in one of the dates it is harder to tell what they mean, and we might want to search lastdiffed for performance.

At any rate, "Last changed date" in the boolean charts is much more clear and would probably not upset anyone if it was the only way to search by lastdiffed.

Comment 3

10 years ago
Of course I mean delta_ts rather than lastdiffed.
Another suggestion: Bugzilla could have an additional option in Bug Changes, "Search only in last change of bugs". It can be enabled or disabled by default, this IMO must be decided by server administrators.

Ignore my suggestion in comment 0, since it's messy.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 294937
You need to log in before you can comment on or make changes to this bug.