If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI]"

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
9 years ago
a year ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

STR:

- Set javascript.options.showInConsole to True
- Select some text in a page and drag it to your locationbar
- Open Error console

Result:

Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: file:///C:/Users/Ria/Desktop/firefox/modules/utils.js :: PU__uri :: line 152"  data: no]

Regression range is:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1205733600&maxdate=1205739479
with bug 394252, bug 423085, bug 423169 and Bug 423083 in it.
Flags: wanted-firefox3.1?
I was not able to reproduce this.
could be also due to bug 454595 since the locationbar accept every floavor actually, though i don't know the regwindow of that bug.

For sure setting showinconsole e strict mode i see this when dropping:
Error: uncaught exception: 2147942487
Error: uncaught exception: 2147942487
ando so on...
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080910043000 Minefield/3.1b1pre

windows only?
i see the same when dropping to places views
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20080910064831 Minefield/3.1b1pre

Still reproducible.
Even without javascript.options.showInConsole to true.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a1pre) Gecko/2008060104 Minefield/3.1a1pre

Easiest way to reproduce:
- Open tab with about:config
- Highlight part of config in the url bar - I selected 'nfig'
- Drag partial highlight to about:config filter box
- Open Error Console to view the error

I see this way back since 6/01 [didn't dare to go any farther], after a certain point in July, the javascript.options.showInConsole pref is not needed to view the error as it shows up with it set to false. Seems if you grab all of about:config from the url bar and drag to filter box, error is not thrown.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081105 Firefox/3.0

Hmm using my repro on this build seems to produce this instead:
Error: ib is undefined
Source File: chrome://browser/content/places/toolbar.xml
Line: 984

javascript.options.showInConsole MUST be set to true. Tested with it off, no error. 

Also when you hover your dragged selection over the bookmarks toolbar, it causes the error to repeat fiercely - have error console open in the background to witness this. Hovering my dragged selection over the tab bar and filter box for a prolonged amount of time did not spew the error.
(In reply to comment #8)

> Hmm using my repro on this build seems to produce this instead:
> Error: ib is undefined
> Source File: chrome://browser/content/places/toolbar.xml
> Line: 984

that is bug 461637
Still able to reproduce since bug 461637 has been fixed?

Updated

9 years ago
Flags: wanted-firefox3.5? → wanted-firefox3.6?
Ria, is this still reproduceable?
I see a similar error running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b2pre) Gecko/20091019 Namoroka/3.6b2pre - Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: file:///Users/marcia/Desktop/Namoroka/Namoroka.app/Contents/MacOS/components/nsSessionStore.js :: sss_deserializeHistoryEntry :: line 2080"  data: no]
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks

Updated

5 years ago
Flags: wanted-firefox3.6?

Comment 14

a year ago
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID 	20160519030232

Works for me on latest Nightly so I will close the bug. If anyone can still reproduce the issue on a current build, fell free to reopen it.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.