f keys don't work for undo, cut, copy, paste.

RESOLVED DUPLICATE of bug 429824

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 429824
11 years ago
11 years ago

People

(Reporter: david, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

In System Prefs, we can set Keyboard Shortcuts for All Applications as F1=Undo, F2=Cut, F3=Copy, F4=Paste. Firefox displays the F keys correctly in the menus, but we are forced to use Command-Z, Command-X, Command-C, Command-V everywhere in the browser.

Reproducible: Always

Steps to Reproduce:
1. Assign F keys in Sys Prefs->Keyboard & Mouse->Keyboard Shortcuts->Application Keyboard Shortcuts->All Applications
2. Launch Firefox
3. Attempt to use F1-F4 for Undo, Cut, Copy, Paste. Won't work. Only command keys work.
Actual Results:  
Can't use F keys for what works in every other application

Expected Results:  
Use F keys for Undo, Cut, Copy, Paste, as we do in every other application
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
You need to log in before you can comment on or make changes to this bug.