Menus, especially Bookmark menu, don't work well on tabletPC

RESOLVED WORKSFORME

Status

()

Firefox
Menus
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: JS, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16

Whenever I click on an item that opens a submenu with the pen of the tablet PC then menu opens but the item is not highlighted. If I click it again it will be highlighted.

But that's not the problem. 

If the item is not highlighted but the submenu is open and then I click on another item to open a submenu in the same level as the first the first submenu is NOT closed but the new one is opened.

Now when I click a bookmark to open the URL all submenus that were opened without a highlighted parent item none is closed.

Reproducible: Always

Steps to Reproduce:
1. open a menu (bookmarks menu is good because it has many levels)
2. click with pen (not mouse as this highlights menu items when rolling over them) an item to open a submenu
3. submenu opens, item is not highlighted
4. click another item to open a submenu in the same level as the first item
5. submenu opens but first submenu is still open
Actual Results:  
When I click a bookmark to open the URL all submenus that were opened without a highlighted parent item none is closed.

Expected Results:  
Submenus close.

This cannot be tested with a mouse as this highlights menu items when rolling over them.
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Updated

10 years ago
Version: 2.0 Branch → unspecified
(Reporter)

Comment 1

9 years ago
Works with FF 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.