Delete doesn't enable in some cases using Next Unread.

VERIFIED DUPLICATE of bug 84260

Status

P3
normal
VERIFIED DUPLICATE of bug 84260
19 years ago
15 years ago

People

(Reporter: laurel, Assigned: sspitzer)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cut 8/28] relnote-user)

(Reporter)

Description

19 years ago
Using july 5 commercial build
Seen using NT 4.0 and linux rh6.0
Haven't tried mac yet

Delete is often not enabling when landing on a message via Next Unread after
having switched folders or when first launching mail, logging into mail account
and using Next to read new messages in inbox.

1.  Launch IMAP profile to mail which you know will have some new messages in
the inbox. 
2.  Select INBOX if not already autoselected and provide proper login password.
3.  Let folder finish loading, notice the Delete button is disabled.
4.  Click Next (Unread) button. Lands you on the next unread message, message
loads in message pane.  Notice the delete button is still disabled, can't use it
to delete.  The button will stay disabled until you manually select a message in
the thread pane or may clear if switching folders.

Note:  Same thing occurs frequently when switching among folders and using Next
within a newly selected folder.

Result:  Delete button stays disabled until you select thread ("manually") in
thread pane.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel

Comment 1

19 years ago
I see this too. Moving to M18 and nominating for beta3.
Status: NEW → ASSIGNED
Keywords: nsbeta3
Target Milestone: --- → M18
(Reporter)

Updated

19 years ago
Keywords: relnote2

Updated

19 years ago
Keywords: mail2

Comment 2

19 years ago
+ per mail triage
Whiteboard: [nsbeta3+]

Comment 3

19 years ago
reassigning to varada.  This is actually a focus bug.  It's not enabling because
focus is on the folder pane and the inbox is selected. If you were on another
folder and hit delete then it would try to delete the folder. We need to get
focus on the thread pane.
Assignee: putterman → varada
Status: ASSIGNED → NEW

Comment 4

19 years ago
adding myself to cc list.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 5

19 years ago
second pass: - per mail triage
Whiteboard: [nsbeta3+] → [nsbeta3-][cut 8/28]
(Reporter)

Updated

19 years ago
Keywords: relnote3, relnoteRTM

Comment 6

19 years ago
removing mail2 keyword.
Keywords: mail2
Whiteboard: [nsbeta3-][cut 8/28] → [nsbeta3-][cut 8/28] relnote-user
(Reporter)

Updated

19 years ago
QA Contact: laurel → sheelar

Comment 7

19 years ago
Re-assigning bug to sspitzer as per putterman.
Assignee: varada → sspitzer
Status: ASSIGNED → NEW
clearing milestone, m17 and m18 are meaningless now.  these need to be triages
along with the rest.
Target Milestone: M18 → ---

Updated

18 years ago
Keywords: nsbeta3, relnote2, relnote3
Whiteboard: [nsbeta3-][cut 8/28] relnote-user → [cut 8/28] relnote-user

Comment 9

18 years ago
This works fine for me in 030608 mozilla linux build.  I followed laurel's steps
exactly and Delete was enabled.  Laurel, are you still seeing this?

Comment 10

18 years ago
Deleting is horrible still.  I tried to delete 156 mail docs from my inbox.  It
took 4 attempts.  The screen flickered and flashed and many docs. were still
left in my inbox and I had to do it over and over again until they were gone. 
Main is our most important use of this application and I hope it is fixed before
the next beta.
Asa: I see this, and can reproduce it with the original steps 100%. I was going
to file a bug on it if I hadn't found this. And indeed, it is a focus issue.
When the box is selected (e.g. by clicking on it), and you then press N, along
with the message header mechanically being selected and the message displayed if
the message pane is open, focus should shift to the message pane (IMO) or
alternatively the header pane. This should enable the delete button /
accelerator key.

rcoyle@pfshouston.com, I believe what you are seeing is a different bug which
was fixed a while back (I haven't seen it for a long time, that is).

Comment 12

18 years ago
I don't think it's completely a focus problem. Note that the thread pane *does*
get the focus after clicking on a mailbox (which makes it sucky to navigate the
folder hierachy by keyboard - maybe that should be filed as a bug).

The bug is still reproducable, but only if you use keyboard navigation -
pressing "N" or "F" after selecting a folder will do it. The problem does not
occur if you click on the "Next" button. Interestingly, you can still delete the
message using the keyboard, even though the Delete button is disabled.

Given it's only a problem when using the keyboard, shouldn't this have the
keyword "access"?
I'll look into the bug further.

Comment 13

18 years ago
The problem with this is nsMsgDBView::GetCommandStatus() is incorrectly
returning false when called by DefaultController.isCommandEnabled() in
mail3PaneWindowCommands.js (and possibly by others)

Interestingly, fixing bug 97134 fixes this, so either something is broken in
nsUInt32Array or nsMsgDBView::GetSelectedIndices().

I'll look further into precisely which of those two are broken.

Comment 14

18 years ago
Adding myself to the CC list, aplogies for the spam.

Updated

18 years ago
Depends on: 97421

Comment 15

18 years ago
The root cause of the problem is the outliner's over-anxious key event handlers.
Pressing a key causes the thread outliner to select a non-existing row. This
error the propagates up to nsMsgDBView::GetCommandStatus() via
nsMsgDBView::GetSelectedIndices().

Fixing the outliner's handler (bug 97421) fixes this bug.
No longer depends on: 97421

Comment 16

18 years ago
This may be a related problem. The following was tested under Mac/0.9.3 and
Mac/2001090508.

1. Select an IMAP folder with one and only one message inside
2. Observe focus is now on message pane
3. Select All using the keyboard (Cmd- or Ctrl-a)
4. Observe that the message is selected but the Delete button is not enabled

This only occurs if there is one and only one message in the folder. Deselecting
the selected message and reselecting all using the keyboard causes the Delete
button to enable.

Choosing Select All from the menu does always cause the Delete button to enable.

What do you think? Is this part of this bug, or should I open a new one?

(Propose that this bug is All/All.)

Comment 17

18 years ago
It looks like the same problem - any way you can cause a single message to be
selected after selecting a folder using keystrokes will reproduce this behaviour.

Comment 18

18 years ago
Blocked by bug 97421
Depends on: 97421

Comment 19

18 years ago
This has been fixed in bug 84260.

(Reporter)

Comment 20

18 years ago
*** Bug 113937 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
dup

*** This bug has been marked as a duplicate of 84260 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 22

18 years ago
this is a dup of a fixed bug. removing item for this bug from release notes.

Comment 23

18 years ago
verified as dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.