Closed Bug 445731 Opened 15 years ago Closed 15 years ago

Editing an saved event with an attendee -> 2 mails were send, one 'Event Invitation', one Event Canceled'

Categories

(Calendar :: E-mail based Scheduling (iTIP/iMIP), defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: andreas.treumann, Assigned: dbo)

Details

(Keywords: dataloss)

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- create an event with one attendee and invite him via iTIP/iMIP
- save this event and send out the invitation
- reopen the event
- add a second attendee and save the event (two times 'Notify Attendees dialog - but I think this is a minor issue)
- send out both notifications

RESULT:
=======

- the first attendee gets two Event notification mails. The first is a 'Event invitation'-mail, the second a 'Event Canceled'-Mail!


EXPECTED RESULT:
================

- no user should get a 'Event Canceled'-MAil without the event is realy canceled. 

REPRODUCIBLE:
=============

- always
Flags: wanted-calendar0.9?
Assignee: nobody → daniel.boelzle
Flags: wanted-calendar0.9? → blocking-calendar0.9+
Maybe this second scenario is caused by the same bug:

- event with two attendees
- remove one
- this on gets also two invitation mails, first the cancellation and then a new event invitation.
Adding a Location or description to an event with only one attendee causes the same behavior, one invitation mail and a second cancellation mail -> I change the bug title.
Summary: Add an second attendee to an event -> first gets 2 emails, one 'Event Invitation', one Event Canceled' → Editing an saved event with an attendee -> 2 mails were send, one 'Event Invitation', one Event Canceled'
Andreas, I cannot reproduce the bug description as well as the description in comment #1 anymore; maybe it's been fixed in the meanwhile. What I have fixed is the double confirmation with this patch.
Attachment #332528 - Flags: review?(philipp)
Status: NEW → ASSIGNED
@Daniel: I checked this issue again and it's also not possible form me to reproduce this bug anymore. 
Comment on attachment 332528 [details] [diff] [review]
fixing double confirmation

Looks good, r=philipp
Attachment #332528 - Flags: review?(philipp) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH => FIXED.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.9
Checked in lightning build 2008081103 -> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.