Pasting data from Excel adds space

RESOLVED DUPLICATE of bug 432415

Status

()

Toolkit
Form Manager
--
major
RESOLVED DUPLICATE of bug 432415
10 years ago
9 years ago

People

(Reporter: Yury Schwartz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

In new Mozilla Firefox 3.0.x every time a data is pasted from MS Excel 2003 cells into Firefox forms, a space is added. During validations errors occur.

For example, I paste ID "sam" and PW "john" into form's fields. Firefox 3.0 pastes ID "sam " and PW "john " - WITH added spaces!!!! Of course, form validation does not work.

It is not happening in Firefox 2.x! Tested many times.

I store my web passwords in Excel file and now it is a pain in the neck to delete last character each time I copy/paste them into web forms.

Reproducible: Always

Steps to Reproduce:
1. Enter data "sam" in Excel 2003 file.
2. Copy data "sam" from Excel file and paste into any web form in Firefox 3.x
3. The pasted data is now "sam " with added space!!!
Actual Results:  
The data copied/pasted from Excel is a value with added space!!!

Expected Results:  
The data copied/pasted from Excel has to be an exact value as it is in Excel!!!
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 432415
You need to log in before you can comment on or make changes to this bug.